APM Filter incoming data

Is there any possibility to filter out APM data (errors, specific urls, ...), so that apm-server does not index them to elasticsearch?

Or is the only way to set the apm-server output to logstash and drop unwanted data in logstash?

This is doable but I think this is a huge performance overhead, so directly filtering in apm-server would be prefered if possible

In the Java agent you can use the ignore_exceptions and the transaction_ignore_urls config options to achieve that.

Otherwise, you can use Ingest pipelines with a drop processor for that.

I hope this helps.

1 Like

Thanks @Eyal_Koren ... Didn't know this options, but this may do it.

I've tested ignore_exceptions and this works fine, but have a question about "transaction_ignore_urls"
I've set this:

But e.g. is still instrumented.

Do I have here any misconfiguration?

If you are matching against exactly, then your configuration should work. If this is not the exact and full URL, then use a wildcard at the end of the pattern.
Otherwise, please provide your exact configurations, a debug log and the full URL that should being matched and doesn't, maybe we can find why.


in my elasticapm.properties i have set:

But still find entries in my apm-indices with this url.

We have set the following configuration - parameters:

  • application_packages
  • service_name
  • environment
  • server_urls

You formerly reported you tried transaction_ignore_urls=/devops/alive - did that not work as well?

Some trial and error can be useful, for example:

  • transaction_ignore_urls=*devops/alive*
  • transaction_ignore_urls=*devops*


Also, set log_level to debug and make sure your configuration is picked up as expected.

The "transaction_ignore_urls" is not picked up regarding DEBUG-log, i see all my parameters from config-file, but transaction_ignore_urls seems to be "ignored" ...

When setting this in Kibana with central configuration, I see in the logs "WARN co.elastic.apm.agent.configuration.ApmServerConfigurationSource - Received unknown remote configuration key transaction_ignore_urls"

Do you have any idea why his happens?

@Eyal_Koren seems like this is caused by an old version of elastic-apm-agent. I will update to newest version and then this ignore_urls should work.

Thanks for all your feedback and help

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.