APM indices does not oblige the index pattern given in yaml if ILM is enabled

I am facing a strange issue with index naming pattern of apm. If i keep ILM enabled, the name will be apm-7.4.2-XXX-000001. However i have the default date pattern set in the server yaml.

If i disable ILM, the index names are as expected "apm-7.4.2-XXX-2020.01.30.

Is there any config / setting which is overriding the default index naming pattern.

Elasticsearch Version : 7.4.0
APM Version : 7.4.2

Hi Ashwin,

This is expected, as ILM only works with the default index settings. As stated in those docs, when ilm.enabled is true, the APM Server ignores any configured index settings.

If it's important for you to have custom named indices, you can use Elasticsearch APIs to set up custom index lifecycle management policies. Fair warning, this process is more difficult, and certain actions will need to be preformed again each time you upgrade.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.