Authorization Problem

Isnt there a built in user ("superuser") on active -directory realm?

Why is it giving an error when I give the superuser role to my account?

If you are getting that error, then your user does not have the superuser role.

You can use the authenticate API to check the roles that your user has.

If you provide more details then we can help track down the problem.

1 Like

Seems like I dont even have a user. How to I authenticate though.

I am leaving the roles.yml empty because superuser role is default right? (or did I do the dumbest mistakeby leaving it empty)

Your original error message referred to the user h_akar5, but the authenticate output is for the elastic user.

You need to call the authenticate API using your h_akar5 user if you want to test anything.

If you're using curl, pass -u h_akar5 as a command line parameter.

1 Like

The problem was I was doing the role mapping in kibana/x-pack/config instead of elasticsearch/x-pack/config and I had no idea.

So now it works like a charm. On the authorization about document level security we use the query:
"match_phrase": {"component":"BİLGİ GÜVENLİĞİ MÜDÜRLÜĞÜ"}
How do I get the response for like multiple components? I tried:

"match_phrase": {"component":"BİLGİ GÜVENLİĞİ MÜDÜRLÜĞÜ"},
"match_phrase": {"component":"ORTAK ÇÖZÜMLER MÜDÜRLÜĞÜ"}

But no success. How do I make an or statement to get both components in the same dashboard?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.