Automatic Write Block on Index

I have 3 master and 3 data nodes. I was getting this error:
AuthorizationException(403, 'cluster_block_exception', 'blocked by: [FORBIDDEN/8/index write (api)];')

Increased the data nodes by 1 but still getting the same error.

Disk usage after adding a node:

shards disk.indices disk.used disk.avail disk.total disk.percent 
    11        7.2gb     8.3gb     11.2gb     19.5gb           42 x.x.x.x x.x.x.x 
    10       14.5gb    15.6gb      3.9gb     19.5gb           79 x.x.x.x  x.x.x.x   
    10        7.2gb     8.3gb     11.2gb     19.5gb           42 x.x.x.x x.x.x.x  
    11       14.5gb    15.6gb      3.9gb     19.5gb           80 x.x.x.x x.x.x.x  

I tried updating the write block on my index to false in the settings but it become true in few seconds:

    "settings": {
        "index": {
            "refresh_interval": "10s",
            "number_of_shards": "3",
            "blocks": {
                "read_only": "false",
                "write": "true"
            },

......
Elasticsearch version "6.2.3"

Do I need more nodes/storage?

Any log file excerpts you might be able to share? Also, can you check with the nodes info/stats APIs how much disk space elasticsearch assumes it has.

There is a feature to block indexing if you run out of disk space, so maybe that is triggering in some way.

1 Like

Welcome to our community! :smiley:

I would recommend upgrading, 6.2 is EOL :slight_smile: