Elasticsearch Error {type:cluster_block_exception,reason:"blocked by: [FORBIDDEN/12/index read-only / allow delete (api)];}

before three days i got below error on production enviroment:
{"type":"cluster_block_exception","reason":"blocked by: [FORBIDDEN/12/index read-only / allow delete (api)];"}
i applied below command, then it it worked well:

curl -XPUT -H "Content-Type: application/json" http://HOSTNAME:9200/_all/_settings -d '{"index.blocks.read_only_allow_delete": null}'

now i am getting same error again

Size Used Avail Use% Mounted on
49G 30G 19G 61%
any help please

It typically means that you at some point, e.g. during a large merge, have exceeded the flood stage watermark and had very little disk space left. Do you have any indices with very large shards in the cluster that could drive up disk usage when merging? Do you perform a lot of updates on your indices?

i think available disk space is enough
Please check attached screenshots

The only reason this block is added is when you ran low on disk space, possibly temporarily. Check your logs for messages from the DiskThresholdMonitor explaining why this block was added.

Can you provide the output of the ‘_cat/indices’ API?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.