Cluster_block_exception


(Aviyoosh) #1

Hi,
When trying to add documents to index :
put my_index_name/doc/5

i get this error:
{
"error": {
"root_cause": [
{
"type": "cluster_block_exception",
"reason": "blocked by: [FORBIDDEN/12/index read-only / allow delete (api)];"
}
],
"type": "cluster_block_exception",
"reason": "blocked by: [FORBIDDEN/12/index read-only / allow delete (api)];"
},
"status": 403
}

after reading some topics regarding this, i also ran -> which solved the issue but only for 1 document:
PUT my_index_name/_settings
{
"index": {
"blocks": {
"read_only_allow_delete": "false"
}
}
}

next document i needed to run the settings query again.

which command i need to run in order to solve this "for good"? for all my indexes?

Thanks


(David Pilato) #2

Look at the logs but you are most likely running low on disk space.


(Aviyoosh) #3

according to what i've read - it's a matter of permissions/privileges.
because after the second part of the question - it is fixing it.


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.