Average system.cpu.system always near 100%

Hello, i don't know if it's supposed to work like that but i tried to visualize the cpu usage (system.cpu.system.pct) and the memory usage (system.memory.actual.used.pct) but in both graphs the value make a straight line near 100%.

For the cpu i tried to split by core.id but if i do that the value does a straight line near 0% and i have only one line.
FYI i'm trying to do someting like the graphs in the task manager on windows.
thanks in advance for your reply.

@Arnolin have you configured metricbeat with the correct cpu metrics? Please try to enable normalized_percentages and then query system.cpu.system.norm.pct. That will show you a normalized cpu usage always less than 100% even when u have more than one core.

I tried with the normalized percentages but now i have a flat line a 0.0%

In order to debug this, try checking the values with the discovery tab, so you see what gets reported.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.