Azure Repository Plugin access denied to elasticsearch.keystore


(Brandon Michael Hunter) #1

I've installed Azure Repository plugin into my 6.4 ES instance on my Ubuntu 16.04.5 LTS box which is hosted inside of a VM in Azure. I'm trying to perform backups and restores using a storage account I created in azure. When I try to set the account and key values I get the following error from the console:
"Exception in thread 'main' java.nio.file.AccessDeniedException: /etc/elasticsearch/elasticsearch.keystore".
I've tried running on sudo and still the same error.

Provided below is an the error when I try to set the account value from a txt file and the permissions set on the /etc/elasticsearch/elasticsearch.keystore, /etc/elasticsearch and /usr/share/elasticsearch/bin folders.


(Ryan Ernst) #2

What are the permissions of /etc/elasticsearch (not the contents)?


(Brandon Michael Hunter) #3

ESPermissionsonEtcElasticSearch
ESFolderPermissionOnElasticSearch

See the images above.
The first one is the permissions on the file permissions within the /etc/elasticsearch folder and the second is the folder permissions for elasticsearch.


(Brandon Michael Hunter) #4

0down vote[accept](javascript:void(0):wink:

I'd resolved my issue by updating the following permissions on the elasticsearch.keystore file. Tell me if this is the right way to do it..

sudo chmod a+rwx /etc/elasticsearch/elasticsearch.keystore - All Users
sudo chmod u+rwx /etc/elasticsearch/elasticsearch.keystore - Group
sudo chmod g+rwx /etc/elasticsearch/elasticsearch.keystore - Owner

(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.