Azure Storage Repo problem


(Elvo) #1

Hello,

I have problem with connecting with azure storage repository
with elasticsearch-cloud-azure plugin.
I installed the plugin on all machines in cluster.
I added content to elasticsearch.yml file like:

cloud:
azure:
account: name
key: loooooooooooongkey

After reeboot the cluster is up&running, but when I try to use command:

curl -XPUT 'http://localhost:9200/_snapshot/my_backup1' -d '{

"type": "azure"

}'

I'm receiving this error:

{"error":"RemoteTransportException[[hostname][inet[/10.xx.xx.xx:9300]][cluster/repository/put]];
nested: RepositoryException[[my_backup1] failed to create repository];
nested: ConfigurationException[Guice configuration errors:\n\n1) No
implementation for org.elasticsearch.repositories.Repository was bound.\n
at org.elasticsearch.repositories.Repository\n\n1 error]; ","status":500}

Any ideas what is wrong with it?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/6bb096d6-2d9d-4a3d-a9d7-f9a3c936d125%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #2

Can you look at logs?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 7 août 2014 à 21:41:45, Elvo (michal@swigut.pl) a écrit:

Hello,

I have problem with connecting with azure storage repository with elasticsearch-cloud-azure plugin.
I installed the plugin on all machines in cluster.
I added content to elasticsearch.yml file like:

cloud:
azure:
account: name
key: loooooooooooongkey

After reeboot the cluster is up&running, but when I try to use command:

curl -XPUT 'http://localhost:9200/_snapshot/my_backup1' -d '{
"type": "azure"
}'

I'm receiving this error:

{"error":"RemoteTransportException[[hostname][inet[/10.xx.xx.xx:9300]][cluster/repository/put]]; nested: RepositoryException[[my_backup1] failed to create repository]; nested: ConfigurationException[Guice configuration errors:\n\n1) No implementation for org.elasticsearch.repositories.Repository was bound.\n at org.elasticsearch.repositories.Repository\n\n1 error]; ","status":500}

Any ideas what is wrong with it?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/6bb096d6-2d9d-4a3d-a9d7-f9a3c936d125%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.53e3d69d.507ed7ab.18f0%40MacBook-Air-de-David.local.
For more options, visit https://groups.google.com/d/optout.


(Elvo) #3

I see nothing inside :confused:

W dniu czwartek, 7 sierpnia 2014 21:42:42 UTC+2 użytkownik David Pilato
napisał:

Can you look at logs?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfr
https://twitter.com/elasticsearchfr

Le 7 août 2014 à 21:41:45, Elvo (mic...@swigut.pl <javascript:>) a écrit:

Hello,

I have problem with connecting with azure storage repository
with elasticsearch-cloud-azure plugin.
I installed the plugin on all machines in cluster.
I added content to elasticsearch.yml file like:

cloud:
azure:
account: name
key: loooooooooooongkey

After reeboot the cluster is up&running, but when I try to use command:

curl -XPUT 'http://localhost:9200/_snapshot/my_backup1' -d '{

"type": "azure"

}'

I'm receiving this error:

{"error":"RemoteTransportException[[hostname][inet[/10.xx.xx.xx:9300]][cluster/repository/put]];
nested: RepositoryException[[my_backup1] failed to create repository];
nested: ConfigurationException[Guice configuration errors:\n\n1) No
implementation for org.elasticsearch.repositories.Repository was bound.\n
at org.elasticsearch.repositories.Repository\n\n1 error]; ","status":500}

Any ideas what is wrong with it?

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/6bb096d6-2d9d-4a3d-a9d7-f9a3c936d125%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/6bb096d6-2d9d-4a3d-a9d7-f9a3c936d125%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/892c5ede-34eb-4f94-990f-74284fb6cb3a%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #4

could you change logging:

cloud.azure: TRACE
repositories.azure: TRACE

And run the same test. Then GIST the log file?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 7 août 2014 à 21:44:34, Elvo (michal@swigut.pl) a écrit:

I see nothing inside :confused:

W dniu czwartek, 7 sierpnia 2014 21:42:42 UTC+2 użytkownik David Pilato napisał:
Can you look at logs?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 7 août 2014 à 21:41:45, Elvo (mic...@swigut.pl) a écrit:

Hello,

I have problem with connecting with azure storage repository with elasticsearch-cloud-azure plugin.
I installed the plugin on all machines in cluster.
I added content to elasticsearch.yml file like:

cloud:
azure:
account: name
key: loooooooooooongkey

After reeboot the cluster is up&running, but when I try to use command:

curl -XPUT 'http://localhost:9200/_snapshot/my_backup1' -d '{
"type": "azure"
}'

I'm receiving this error:

{"error":"RemoteTransportException[[hostname][inet[/10.xx.xx.xx:9300]][cluster/repository/put]]; nested: RepositoryException[[my_backup1] failed to create repository]; nested: ConfigurationException[Guice configuration errors:\n\n1) No implementation for org.elasticsearch.repositories.Repository was bound.\n at org.elasticsearch.repositories.Repository\n\n1 error]; ","status":500}

Any ideas what is wrong with it?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/6bb096d6-2d9d-4a3d-a9d7-f9a3c936d125%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/892c5ede-34eb-4f94-990f-74284fb6cb3a%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.53e3d988.79e2a9e3.18f0%40MacBook-Air-de-David.local.
For more options, visit https://groups.google.com/d/optout.


(Elvo) #5

on master I can see: https://gist.github.com/anonymous/12aaf25b15654a562704

With logging settings - should I change it on all machines in cluster and
reboot them?

W dniu czwartek, 7 sierpnia 2014 21:55:07 UTC+2 użytkownik David Pilato
napisał:

could you change logging:

cloud.azure: TRACE
repositories.azure: TRACE

And run the same test. Then GIST the log file?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfr
https://twitter.com/elasticsearchfr

Le 7 août 2014 à 21:44:34, Elvo (mic...@swigut.pl <javascript:>) a écrit:

I see nothing inside :confused:

W dniu czwartek, 7 sierpnia 2014 21:42:42 UTC+2 użytkownik David Pilato
napisał:

Can you look at logs?

 -- 

David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfr
https://twitter.com/elasticsearchfr

Le 7 août 2014 à 21:41:45, Elvo (mic...@swigut.pl) a écrit:

Hello,

I have problem with connecting with azure storage repository
with elasticsearch-cloud-azure plugin.
I installed the plugin on all machines in cluster.
I added content to elasticsearch.yml file like:

cloud:
azure:
account: name
key: loooooooooooongkey

After reeboot the cluster is up&running, but when I try to use command:

curl -XPUT 'http://localhost:9200/_snapshot/my_backup1' -d '{

"type": "azure"

}'

I'm receiving this error:

{"error":"RemoteTransportException[[hostname][inet[/10.xx.xx.xx:9300]][cluster/repository/put]];
nested: RepositoryException[[my_backup1] failed to create repository];
nested: ConfigurationException[Guice configuration errors:\n\n1) No
implementation for org.elasticsearch.repositories.Repository was bound.\n
at org.elasticsearch.repositories.Repository\n\n1 error]; ","status":500}

Any ideas what is wrong with it?

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/6bb096d6-2d9d-4a3d-a9d7-f9a3c936d125%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/6bb096d6-2d9d-4a3d-a9d7-f9a3c936d125%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/892c5ede-34eb-4f94-990f-74284fb6cb3a%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/892c5ede-34eb-4f94-990f-74284fb6cb3a%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/c6218bc1-ae0b-41a2-a153-642fe2d24cb5%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #6

Without restarting anything, you can also run:

curl -XPUT localhost:9200/_cluster/settings -d '{
"transient" : {
"logger.cloud.azure" : "TRACE",
"logger.repositories.azure" : "TRACE"
}
}'

This should work

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 7 août 2014 à 22:03:02, Elvo (michal@swigut.pl) a écrit:

on master I can see: https://gist.github.com/anonymous/12aaf25b15654a562704

With logging settings - should I change it on all machines in cluster and reboot them?

W dniu czwartek, 7 sierpnia 2014 21:55:07 UTC+2 użytkownik David Pilato napisał:
could you change logging:

cloud.azure: TRACE
repositories.azure: TRACE

And run the same test. Then GIST the log file?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 7 août 2014 à 21:44:34, Elvo (mic...@swigut.pl) a écrit:

I see nothing inside :confused:

W dniu czwartek, 7 sierpnia 2014 21:42:42 UTC+2 użytkownik David Pilato napisał:
Can you look at logs?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 7 août 2014 à 21:41:45, Elvo (mic...@swigut.pl) a écrit:

Hello,

I have problem with connecting with azure storage repository with elasticsearch-cloud-azure plugin.
I installed the plugin on all machines in cluster.
I added content to elasticsearch.yml file like:

cloud:
azure:
account: name
key: loooooooooooongkey

After reeboot the cluster is up&running, but when I try to use command:

curl -XPUT 'http://localhost:9200/_snapshot/my_backup1' -d '{
"type": "azure"
}'

I'm receiving this error:

{"error":"RemoteTransportException[[hostname][inet[/10.xx.xx.xx:9300]][cluster/repository/put]]; nested: RepositoryException[[my_backup1] failed to create repository]; nested: ConfigurationException[Guice configuration errors:\n\n1) No implementation for org.elasticsearch.repositories.Repository was bound.\n at org.elasticsearch.repositories.Repository\n\n1 error]; ","status":500}

Any ideas what is wrong with it?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/6bb096d6-2d9d-4a3d-a9d7-f9a3c936d125%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/892c5ede-34eb-4f94-990f-74284fb6cb3a%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/c6218bc1-ae0b-41a2-a153-642fe2d24cb5%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.53e3dc05.5bd062c2.18f0%40MacBook-Air-de-David.local.
For more options, visit https://groups.google.com/d/optout.


(Elvo) #7

now it's beeter, I got:

[2014-08-07 22:07:34,144][DEBUG][cluster.service ] [HOSTNAME]
processing [put_repository [my_backup1]]: execute
[2014-08-07 22:07:34,144][DEBUG][repositories ] [HOSTNAME]
creating repository [azure][my_backup1]
[2014-08-07 22:07:34,146][TRACE][repositories.azure ] [HOSTNAME]
azure repository is not set using storage_account and storage_key properties
[2014-08-07 22:07:34,146][DEBUG][repositories.azure ] [HOSTNAME]
disabling azure snapshot and restore features
[2014-08-07 22:07:34,147][WARN ][repositories ] [HOSTNAME]
failed to create repository [azure][my_backup1]

But... I have those settings included, or should I use storage_account
instead of account setting name in config?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/0d8d4588-c613-4d6c-a96e-46a17230e6de%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #8

Yes your elasticsearch.yml file in incorrect.

Read this: https://github.com/elasticsearch/elasticsearch-cloud-azure#azure-repository

cloud:
azure:
storage_account: your_azure_storage_account
storage_key: your_azure_storage_key

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 7 août 2014 à 22:11:41, Elvo (michal@swigut.pl) a écrit:

now it's beeter, I got:

[2014-08-07 22:07:34,144][DEBUG][cluster.service ] [HOSTNAME] processing [put_repository [my_backup1]]: execute
[2014-08-07 22:07:34,144][DEBUG][repositories ] [HOSTNAME] creating repository [azure][my_backup1]
[2014-08-07 22:07:34,146][TRACE][repositories.azure ] [HOSTNAME] azure repository is not set using storage_account and storage_key properties
[2014-08-07 22:07:34,146][DEBUG][repositories.azure ] [HOSTNAME] disabling azure snapshot and restore features
[2014-08-07 22:07:34,147][WARN ][repositories ] [HOSTNAME] failed to create repository [azure][my_backup1]

But... I have those settings included, or should I use storage_account instead of account setting name in config?

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/0d8d4588-c613-4d6c-a96e-46a17230e6de%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.53e3fabc.66ef438d.18f0%40MacBook-Air-de-David.local.
For more options, visit https://groups.google.com/d/optout.


(system) #9