Babel note: the code generator has deoptimised the styling of 500kb


After I installed a plugin called Mapster ( and restarted the kibana services, I get the following error:
babel note: the code generator has deoptimised the styling of 500kb

This indicates that a file of this plugin is too big. I am not familiar with "babel". Does somebody know how to disable this optimised check or exceed the value of de size?


Best Regards,

@Robin020 that is not much of deal. That is a warning generated by the babel compact option which is set to auto by default (

What is the file that originated the babel warning?


The file is:
[BABEL] Note: The code generator has deoptimised the styling of /usr/share/kibana/plugins/mapster/public/lib/three.min.js as it exceeds the max of 500KB.

I am not familiar with babel so I don't where to change this setting to a larger number. Is it a setting in the plugin or from the system itself?

@Robin020 it is a setting on the kibana optimizer side. Don't worry too much about it :smiley:

Hi Thiago,

But I think my plugin won't start/load in because of this error message. Is it possible to adjust the settings for the kibana optimizer?

@Robin020 what version of Kibana are you using? I don't think that would prevent the plugin to run, it is just a warning.

Kibana version is 7.4.2

Ok, I think I agree with you. I see now these errors:

That's probably my issue...

@Robin020 yeah I think the problem is the plugin itself. In the plugin description it is stated that it supports Kibana 5.2.2, I believe that is the cause for not having the plugin to run

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.