Disable Babel for Kibana Plugin (Development)


(Andrei Costache) #1

Hi,

I am developing a JavaScript (React) plugin for Kibana, version 6.1.3. And I would like to disable Babel, for my plugin, while developing (I do not want my code transpiled). I tried this older suggestion, but it does not work.
I am starting (the development) Kibana using 'sh ./bin/kibana --dev --no-base-path --plugin-path /path/to/plugin'.
Is there any other way to prevent the transpiling process in such a scenario (or on an "outside" plugin directory)?

Thank you in advance,
Andrei.


(Robert Monfera) #2

Hi Andrei, what is it that you actually put in the config file?


(Andrei Costache) #3

Hi Robert,

I modified the src attribute in the babel.js config task, with changes marked below (not all at once)
src: [
'build/kibana/**/*.js',
'!**/public/**',
'!**/node_modules/**',
'!**/bower_components/**',
'!**/__tests__/**',
'!**my_plugin**', // change#1
'!**/my_plugin/**' // change#2
]
I don't know how the resources outside the kibana folder are read. And I admit I am not experienced with grunt/babel (or globbing), so I assume this could be a beginner's mistake.

The location of my plugin, relative to the Kibana dev workspace, is as follows:
/some/path/kibana
/some/path/kibana_plugins_dir/my_plugin

Thank you!


(Robert Monfera) #4

Could you try variations around moving up into the parent directory of the project eg. '!../kibana_plugins_dir/**'?


(Andrei Costache) #5

I have tried several variations, to no result yet.

Is there any other place where such settings can be configured (for instance where the babel task is run, so that I can debug around there maybe)?

Thank you!