Basic documentation question


(Joseph Parish) #1

i have have been going through the docs but cannot get through the basic step that indexes the sample file from this page: https://www.elastic.co/guide/en/elasticsearch/reference/current/_exploring_your_data.html

I get the error below. Im not sure if the file is not in the correct directory or if the content cannot be read (appears to be the issue). Any assistance would be appreciated. Thanks

curl -XPOST 'localhost:9200/bank/account/_bulk?pretty' --data-binary "@accounts.json"
Warning: Couldn't read data from file "accounts.json", this makes an empty
Warning: POST.
{
  "error" : {
    "root_cause" : [ {
      "type" : "parse_exception",
      "reason" : "Failed to derive xcontent"
    } ],
    "type" : "parse_exception",
    "reason" : "Failed to derive xcontent"
  },
  "status" : 400
}

(Nik Everett) #2

Yeah, it looks like accounts.json isn't in the current working directory, that is what is the trouble.


(Alex Brasetvik) #3

Moving to Elasticsearch as this isn't a Cloud-specific question.


(Joseph Parish) #4

thanks i tried locating the file in various locations....which is the working directory? the latest location tried was /../.../Documents/elasticsearch-2.4.0


(Joseph Parish) #5

right....first time here...should i re-post elsewhere?


(Alex Brasetvik) #6

No worries, I've moved the question already. :slight_smile:


(Joseph Parish) #7

thanks


(system) #8

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.