Beginner question


(Jinyuan Zhou) #1

I am following the definitive guide. I added this docume by issue this in
sense
PUT /megacorp/employee/1
{
"first_name" : "John",
"last_name" : "Smith",
"age" : 25,
"about" : "I love to go rock climbing",
"interests": [ "sports", "music" ]
}

when I try to retrieve the docoment
by doing this

GET /megacorp/employee/1

But I didn't get original json back. It get some description of the stored
document like this.
{
"_index": "megacorp",
"_type": "employee",
"_id": "1",
"_version": 2,
"found": true
}.

I did this on command line using cur. Same result come back.

What do I missing? Thanks,

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/73171fd0-dc65-4c3d-9493-5e6b9f62a6ba%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(vineeth mohan-2) #2

Hi ,

Can you try the insert using POST and paste the result.

Thanks
Vineeth

On Sat, Apr 26, 2014 at 9:23 PM, Jinyuan Zhou zhou.jinyuan@gmail.comwrote:

I am following the definitive guide. I added this docume by issue this in
sense
PUT /megacorp/employee/1
{
"first_name" : "John",
"last_name" : "Smith",
"age" : 25,
"about" : "I love to go rock climbing",
"interests": [ "sports", "music" ]
}

when I try to retrieve the docoment
by doing this

GET /megacorp/employee/1

But I didn't get original json back. It get some description of the stored
document like this.
{
"_index": "megacorp",
"_type": "employee",
"_id": "1",
"_version": 2,
"found": true
}.

I did this on command line using cur. Same result come back.

What do I missing? Thanks,

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/73171fd0-dc65-4c3d-9493-5e6b9f62a6ba%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/73171fd0-dc65-4c3d-9493-5e6b9f62a6ba%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAGdPd5%3DASvTuLvDb_ixQOW1krSw70dtX0CpiMXkfLNGrxmY0HQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #3

Can you get your mapping?
May be you disabled _source field?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 26 avr. 2014 à 17:53, Jinyuan Zhou zhou.jinyuan@gmail.com a écrit :

I am following the definitive guide. I added this docume by issue this in sense
PUT /megacorp/employee/1
{
"first_name" : "John",
"last_name" : "Smith",
"age" : 25,
"about" : "I love to go rock climbing",
"interests": [ "sports", "music" ]
}

when I try to retrieve the docoment
by doing this

GET /megacorp/employee/1

But I didn't get original json back. It get some description of the stored document like this.
{
"_index": "megacorp",
"_type": "employee",
"_id": "1",
"_version": 2,
"found": true
}.

I did this on command line using cur. Same result come back.

What do I missing? Thanks,

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/73171fd0-dc65-4c3d-9493-5e6b9f62a6ba%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/13E73F62-48DD-446A-83C2-3AAE696325E7%40pilato.fr.
For more options, visit https://groups.google.com/d/optout.


(Rafał Kuć) #4

Hello!

You should have your results returned unless you disabled _source field in the mappings. Can you show us result of:

curl -XGET 'localhost:9200/megacorp/employee/_mapping?pretty'

--

Regards,

Rafał Kuć

Performance Monitoring * Log Analytics * Search Analytics

Solr & Elasticsearch Support * http://sematext.com/

Hi ,

Can you try the insert using POST and paste the result.

Thanks

       Vineeth

On Sat, Apr 26, 2014 at 9:23 PM, Jinyuan Zhou <zhou.jinyuan@gmail.com> wrote:

I am following the definitive guide. I added this docume by issue this in sense

PUT /megacorp/employee/1

{

"first_name" : "John",


"last_name" :  "Smith",


"age" :        25,


"about" :      "I love to go rock climbing",


"interests": [ "sports", "music" ]

}

when I try to retrieve the docoment

by doing this

GET /megacorp/employee/1

But I didn't get original json back. It get some description of the stored document like this.

{

"_index": "megacorp",

"_type": "employee",

"_id": "1",

"_version": 2,

"found": true

}.

I did this on command line using cur. Same result come back.

What do I missing? Thanks,

--

You received this message because you are subscribed to the Google Groups "elasticsearch" group.

To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/73171fd0-dc65-4c3d-9493-5e6b9f62a6ba%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

--

You received this message because you are subscribed to the Google Groups "elasticsearch" group.

To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAGdPd5%3DASvTuLvDb_ixQOW1krSw70dtX0CpiMXkfLNGrxmY0HQ%40mail.gmail.com.

For more options, visit https://groups.google.com/d/optout.


(Jinyuan Zhou) #5

Thanks yes, I am not running on a clean installation. Yes the _source is
disabled.

{
"megacorp" : {
"mappings" : {
"employee" : {
"_source" : {
"enabled" : false
},
"properties" : {
"about" : {
"type" : "string"
},
"age" : {
"type" : "long"
},
"first_name" : {
"type" : "string"
},
"interests" : {
"type" : "string"
},
"last_name" : {
"type" : "string"
}
}
}
}
}
}

On Saturday, April 26, 2014 9:14:06 AM UTC-7, Rafał Kuć wrote:

Hello!

You should have your results returned unless you disabled _source field in
the mappings. Can you show us result of:

curl -XGET 'localhost:9200/megacorp/employee/_mapping?pretty'

*-- Regards, Rafał Kuć Performance Monitoring * Log Analytics * Search
Analytics Solr & Elasticsearch Support * *http://sematext.com/

Hi ,

Can you try the insert using POST and paste the result.

Thanks
Vineeth

On Sat, Apr 26, 2014 at 9:23 PM, Jinyuan Zhou <zhou.j...@gmail.com<javascript:>>
wrote:
I am following the definitive guide. I added this docume by issue this in
sense
PUT /megacorp/employee/1
{
"first_name" : "John",
"last_name" : "Smith",
"age" : 25,
"about" : "I love to go rock climbing",
"interests": [ "sports", "music" ]
}

when I try to retrieve the docoment
by doing this

GET /megacorp/employee/1

But I didn't get original json back. It get some description of the stored
document like this.
{
"_index": "megacorp",
"_type": "employee",
"_id": "1",
"_version": 2,
"found": true
}.

I did this on command line using cur. Same result come back.

What do I missing? Thanks,

You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/73171fd0-dc65-4c3d-9493-5e6b9f62a6ba%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/73171fd0-dc65-4c3d-9493-5e6b9f62a6ba%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAGdPd5%3DASvTuLvDb_ixQOW1krSw70dtX0CpiMXkfLNGrxmY0HQ%40mail.gmail.comhttps://groups.google.com/d/msgid/elasticsearch/CAGdPd5%3DASvTuLvDb_ixQOW1krSw70dtX0CpiMXkfLNGrxmY0HQ%40mail.gmail.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/d522e62b-a7d0-455f-ac19-8a88f2acd22e%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Jinyuan Zhou) #6

Thanks David, Yet it is mapping. I started from a clean installation. the
json does comeback

On Saturday, April 26, 2014 9:11:48 AM UTC-7, David Pilato wrote:

Can you get your mapping?
May be you disabled _source field?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 26 avr. 2014 à 17:53, Jinyuan Zhou <zhou.j...@gmail.com <javascript:>>
a écrit :

I am following the definitive guide. I added this docume by issue this in
sense
PUT /megacorp/employee/1
{
"first_name" : "John",
"last_name" : "Smith",
"age" : 25,
"about" : "I love to go rock climbing",
"interests": [ "sports", "music" ]
}

when I try to retrieve the docoment
by doing this

GET /megacorp/employee/1

But I didn't get original json back. It get some description of the stored
document like this.
{
"_index": "megacorp",
"_type": "employee",
"_id": "1",
"_version": 2,
"found": true
}.

I did this on command line using cur. Same result come back.

What do I missing? Thanks,

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/73171fd0-dc65-4c3d-9493-5e6b9f62a6ba%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/73171fd0-dc65-4c3d-9493-5e6b9f62a6ba%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/6f5acc67-8357-4aa4-993a-6bfe1bd1a864%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #7