Bootstrap checks failed [1]: max virtual memory areas vm.max_map_count [65530] is too low, increase to at least [262144]


#1

Hi, i got this error when starting ES service, I know we can set this value to 26144 by executing command sysctl -w vm.max_map_count=261244.

But this command will affect whole system, and my production machine has many services not only ES.

Can anyone point me:

  1. How to increase this value only for ES process?
  2. If I increase to 261244, what's the side-effect actually?

Thanks


(Thiago Souza) #2

There is no way to set vm.max_map_count per process. As for side effect, changing the limit itself has none. It exists only if a process actually allocates a large amount of memory maps. Which might happen with Elasticsearch, that's why increasing the setting is needed. That's one of the reasons, among many others, that it is strongly recommended to not run other services on the same host as Elasticsearch on a production environment.


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.