How to bypass vm.max_map_count check upon start?


#1

Hello

I use Elasticsearch 5 in a container (systemd-nspawn) and when I attempt to start it, I get the error

max virtual memory areas vm.max_map_count [65530] is too low, increase to at least [262144]

As mentionned in various places, the virtual memory should be set up to 262144+ on the host, which is the case for my host:

root@the-host:~# sysctl vm.max_map_count
vm.max_map_count = 262144

This setting is also seen as high by the guest (container)

root@the-container:~# sysctl vm.max_map_count
vm.max_map_count = 262144

It therefore looks like ES starting in a container does not assess the value of vm.max_map_count correctly (wild guessing). Is there a way to bypass this check?


(system) #2

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.