Breaking _ingest.timestamp change in ES 5.2.0


(Jin Wang) #1

I have a very simple ingest set processor which copied from our official document, it stop working after upgrading to 5.2.0 yesterday.
{
"set": {
"field": "received"
"value": "{{_ingest.timestamp}}"
}
}

now every document indexing was reject and throw below errors.
{
"error": {
"root_cause": [
{
"type": "mapper_parsing_exception",
"reason": "failed to parse [received]"
}
],
"type": "mapper_parsing_exception",
"reason": "failed to parse [timestamp]",
"caused_by": {
"type": "illegal_argument_exception",
"reason": "Invalid format: "Wed Feb 01 19:02:14 UTC 2017""
}
},
"status": 400
}

Any suggestion about how to get it working without changing my mapping?

Thanks in advance.


Breaking _ingest.timestamp change in ES 5.3.0
(Jin Wang) #2

i solved the problem by replacing the set processor with script processor without changing mapping. possible it is helpful to well document how to use set processor for handling this case.


(Patrick Gottschaemmer) #3

Yes, indeed, I have the same problem.

Unfortunately, imho the docs about ingest.timestamp are pretty incomplete.
There's only one paragraph about it in

https://www.elastic.co/guide/en/elasticsearch/reference/current/accessing-data-in-pipelines.html

where's no information about format or options. As this "replaces" the automatic timestamp mechanic of elasticsearch, I think more information should be supplied.

Anyway, could you please so kind to share your script?
I'd like to keep the default timestamp format and don't change the mapping.

Best regards


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.