Broke Watcher on ES6

So, I ran into some oddities after upgrading from 5.6 and had zero watches so figured I'd just delete the index and let ES recreate it. Upon rebooting my full cluster the index doesn't appear to be recreated and I'm just stuck with this log repeating over and over. WOndering if it's come up before.

[2017-11-29T23:50:48,973][ERROR][o.e.x.m.e.l.LocalExporter] failed to set monitoring watch [MASmnQTrSXuU4_Ls7KXg7w_logstash_version_mismatch]
java.lang.IllegalArgumentException: Rejecting mapping update to [.watches] as the final mapping would have more than 1 type: [watch, doc]
at org.elasticsearch.index.mapper.MapperService.internalMerge( ~[elasticsearch-6.0.0.jar:6.0.0]
at org.elasticsearch.index.mapper.MapperService.internalMerge( ~[elasticsearch-6.0.0.jar:6.0.0]
at org.elasticsearch.index.mapper.MapperService.merge( ~[elasticsearch-6.0.0.jar:6.0.0]
at org.elasticsearch.cluster.metadata.MetaDataCreateIndexService$1.execute( ~[elasticsearch-6.0.0.jar:6.0.0]
at org.elasticsearch.cluster.ClusterStateUpdateTask.execute( ~[elasticsearch-6.0.0.jar:6.0.0]
at org.elasticsearch.cluster.service.MasterService.executeTasks( ~[elasticsearch-6.0.0.jar:6.0.0]
at org.elasticsearch.cluster.service.MasterService.calculateTaskOutputs( ~[elasticsearch-6.0.0.jar:6.0.0]
at org.elasticsearch.cluster.service.MasterService.runTasks( [elasticsearch-6.0.0.jar:6.0.0]
at org.elasticsearch.cluster.service.MasterService$ [elasticsearch-6.0.0.jar:6.0.0]
at org.elasticsearch.cluster.service.TaskBatcher.runIfNotProcessed( [elasticsearch-6.0.0.jar:6.0.0]
at org.elasticsearch.cluster.service.TaskBatcher$ [elasticsearch-6.0.0.jar:6.0.0]
at org.elasticsearch.common.util.concurrent.ThreadContext$ [elasticsearch-6.0.0.jar:6.0.0]
at org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.runAndClean( [elasticsearch-6.0.0.jar:6.0.0]
at org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$ [elasticsearch-6.0.0.jar:6.0.0]
at java.util.concurrent.ThreadPoolExecutor.runWorker( [?:1.8.0_141]
at java.util.concurrent.ThreadPoolExecutor$ [?:1.8.0_141]
at [?:1.8.0_141]

Ok got it, had some stale templates breaking things. After I cleared those out this worked just fine.

Out of curiosity: Have you run the upgrade assistant before and upgraded the watches and triggered watches index?

The watches and triggered indexes refused to upgrade with the upgrade API and it was unused at the time so I didn't care to fix it then. Lesson learned. :slight_smile:

Do you have any errors or logs, why the upgrade was refused? I am getting curious now... anything would help :slight_smile:


Sadly no, usually I like to help, but was in a time crunch. But it was a
pretty basic setup with no watches even started. SO maybe it could be
repo'd going from 5.6 to 6.0

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.