Broken data received on kibana from metricbeat prometheus module

I'm collecting data from 3 targets i.e my network devices through snmp_exporter on prometheus, from there i'm integrating it in elastic and kibana through metricbeat prometheus module, the data is received but its broken or incomplete, like if i want to see two parameters namely Temperature and Ip address of one of my network devices, confirming in discover i can only see IP address with timestamps but the temperature field would be empty and vice-versa, so when i'm trying to setup the dashboards it changes values on every refresh, if i setup a systeminfo table for it, then it will give me IP for 1 device which is sending ip and name for a different device which is not able to send ip but sending name, basically merging whatever values its getting from either of the devices.

Attaching my prometheus server end configuration as well as metricbeat prometheus module,

Please note, the same issue is with the remote_write option as well.
Thanks in advance

- job_name: 'federate'
    scrape_interval: 15s

    honor_labels: true
    metrics_path: '/federate'

    params:
      'match[]': 
        - '{job="prometheus"}'
        - '{__name__=~"job:.*"}'

    static_configs:
      - targets: ["localhost:9090"]

##PROMETHEUS SERVER END CONF##
- module: prometheus
  period: 10s
  metricsets: ["collector"]
  hosts: ["172.xx.xx.xx:9090"]
  metrics_path: '/federate'
  query:
    'match[]': '{__name__!=""}'

## METRICBEAT PROMETHEUS MODULE END CONF ##

@ChrisMark maybe you or someone from the integration teams could give some help here.

1 Like

@Tetiana_Kravchenko any ideas here?

1 Like

Hi, Any updates?

In the meantime i have done some research in Discover area of kibana to Analyze my data and found a fix, on increasing the time period from [10s] to [120s] in the prometheus module of metricbeat, I'm able to get all the data fields for my 3 test network devices.. as in Temperature, Current etc parameters for all the 3 devices.

Only had to give sufficient collection time to the metricbeat by adding period: 120s

Now I'm not sure if this is the solution to it, but definitely works for me. Meanwhile if the team has found a better solution please do share.

Thanks for the support