Bulk index creation problem

Hi,

I am trying to create around 150000 docs in elastic but I got the following
error in elastic log file.
what is the reason of this error and how i can solve this error.
I am using elastic 20.5 and jdk"1.6.0_18 .

please the link for error https://gist.github.com/rajesh07/5501938

please reply
Thanks in advance.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Please follow the installation guidelines at

http://www.elasticsearch.org/guide/reference/setup/installation/

--> Important Configurations - File Descriptors

Not related to the issue: please do not use JDK 1.6.0_18. It is too old
and has bugs. You will run into strange issues with memory. I recommend
the latest Java 7.

Jörg

Am 02.05.13 14:42, schrieb raj:

Hi,

I am trying to create around 150000 docs in elastic but I got the
following error in elastic log file.
what is the reason of this error and how i can solve this error.
I am using elastic 20.5 and jdk"1.6.0_18 .

please the link for error https://gist.github.com/rajesh07/5501938

please reply
Thanks in advance.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Hi,
Thanks for reply.
please can you tell me about "file descriptor"
how can I increase number of open file.

please may you explain it.

Thanks

On Thursday, May 2, 2013 7:08:21 PM UTC+5:30, Jörg Prante wrote:

Please follow the installation guidelines at

http://www.elasticsearch.org/guide/reference/setup/installation/

--> Important Configurations - File Descriptors

Not related to the issue: please do not use JDK 1.6.0_18. It is too old
and has bugs. You will run into strange issues with memory. I recommend
the latest Java 7.

Jörg

Am 02.05.13 14:42, schrieb raj:

Hi,

I am trying to create around 150000 docs in elastic but I got the
following error in elastic log file.
what is the reason of this error and how i can solve this error.
I am using elastic 20.5 and jdk"1.6.0_18 .

please the link for error https://gist.github.com/rajesh07/5501938

please reply
Thanks in advance.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Hi,

I have updated java 7 and also increase the size of open files
descriptor.also I have increased the heap memory
but I got same error.

it's any other change required?
and have elasticsearch any limit of index.

please give me reply.

Thanks

On Thursday, May 2, 2013 7:08:21 PM UTC+5:30, Jörg Prante wrote:

Please follow the installation guidelines at

http://www.elasticsearch.org/guide/reference/setup/installation/

--> Important Configurations - File Descriptors

Not related to the issue: please do not use JDK 1.6.0_18. It is too old
and has bugs. You will run into strange issues with memory. I recommend
the latest Java 7.

Jörg

Am 02.05.13 14:42, schrieb raj:

Hi,

I am trying to create around 150000 docs in elastic but I got the
following error in elastic log file.
what is the reason of this error and how i can solve this error.
I am using elastic 20.5 and jdk"1.6.0_18 .

please the link for error https://gist.github.com/rajesh07/5501938

please reply
Thanks in advance.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Are you sure that you changed the max open files for the user running
elasticsearch? Are you sure that your values were saved for future
sessions? Both are common gotchas when changing the setting. When you open
a shell as the user running elasticsearch, make sure you have a high ulimit
value:

$ ulimit -n

--
Ivan

On Tue, May 7, 2013 at 4:50 AM, raj rajesh.elasticsearch@gmail.com wrote:

Hi,

I have updated java 7 and also increase the size of open files
descriptor.also I have increased the heap memory
but I got same error.

it's any other change required?
and have elasticsearch any limit of index.

please give me reply.

Thanks

On Thursday, May 2, 2013 7:08:21 PM UTC+5:30, Jörg Prante wrote:

Please follow the installation guidelines at

http://www.elasticsearch.org/**guide/reference/setup/**installation/http://www.elasticsearch.org/guide/reference/setup/installation/

--> Important Configurations - File Descriptors

Not related to the issue: please do not use JDK 1.6.0_18. It is too old
and has bugs. You will run into strange issues with memory. I recommend
the latest Java 7.

Jörg

Am 02.05.13 14:42, schrieb raj:

Hi,

I am trying to create around 150000 docs in elastic but I got the
following error in elastic log file.
what is the reason of this error and how i can solve this error.
I am using elastic 20.5 and jdk"1.6.0_18 .

please the link for error https://gist.github.com/**rajesh07/5501938https://gist.github.com/rajesh07/5501938

please reply
Thanks in advance.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

yes i am sure about changed max open files(1024000) for user(root) running
elasticsearch. yes value is saved for future sessions.

any other changed required?

Thanks

On Wednesday, May 8, 2013 3:38:14 AM UTC+5:30, Ivan Brusic wrote:

Are you sure that you changed the max open files for the user running
elasticsearch? Are you sure that your values were saved for future
sessions? Both are common gotchas when changing the setting. When you open
a shell as the user running elasticsearch, make sure you have a high ulimit
value:

$ ulimit -n

--
Ivan

On Tue, May 7, 2013 at 4:50 AM, raj <rajesh.ela...@gmail.com <javascript:>

wrote:

Hi,

I have updated java 7 and also increase the size of open files
descriptor.also I have increased the heap memory
but I got same error.

it's any other change required?
and have elasticsearch any limit of index.

please give me reply.

Thanks

On Thursday, May 2, 2013 7:08:21 PM UTC+5:30, Jörg Prante wrote:

Please follow the installation guidelines at

http://www.elasticsearch.org/**guide/reference/setup/**installation/http://www.elasticsearch.org/guide/reference/setup/installation/

--> Important Configurations - File Descriptors

Not related to the issue: please do not use JDK 1.6.0_18. It is too old
and has bugs. You will run into strange issues with memory. I recommend
the latest Java 7.

Jörg

Am 02.05.13 14:42, schrieb raj:

Hi,

I am trying to create around 150000 docs in elastic but I got the
following error in elastic log file.
what is the reason of this error and how i can solve this error.
I am using elastic 20.5 and jdk"1.6.0_18 .

please the link for error https://gist.github.com/**rajesh07/5501938https://gist.github.com/rajesh07/5501938

please reply
Thanks in advance.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

If you still get the error, check your process how many files are open
with lsof or similar tools.

What result gives ulimit -a?

It is enough to increase nofiles in /etc/security/limits.conf to around
10000 (a few thousand, not millions).

It is not recommended to run ES (or any other app) under root privileges.

Jörg

Am 08.05.13 12:36, schrieb raj:

yes i am sure about changed max open files(1024000) for user(root)
running elasticsearch. yes value is saved for future sessions.

any other changed required?

Thanks

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.