Bundle Update fails when updating snapshot


(Jimmy Kang) #1

Getting this error when I am trying to update my snapshot to install a plugin.

 Bundler could not find compatible versions for gem "logstash":
  In Gemfile:
logstash-output-sqs java was resolved to 0.1.0, which depends on
  logstash (< 2.0.0, >= 1.4.0) java

Could not find gem 'logstash (< 2.0.0, >= 1.4.0) java', which is required by gem
'logstash-output-sqs java', in any of the sources.Bundler could not find
compatible versions for gem "logstash-core":
  In Gemfile:
logstash-core java

logstash-output-sqs java was resolved to 0.1.3, which depends on
  logstash-core (< 2.0.0, >= 1.4.0) java

logstash-output-sqs java was resolved to 0.1.3, which depends on
  logstash-core (< 2.0.0, >= 1.4.0) java

logstash-output-sqs java was resolved to 0.1.3, which depends on
  logstash-core (< 2.0.0, >= 1.4.0) java

Could not find gem 'logstash-core (< 2.0.0, >= 1.4.0) java', which is required
by gem 'logstash-output-sqs java', in any of the sources.

I have set the ruby version to Jruby and when trying to do

bin/logstash-plugin install logstash-output-mongodb

I get an error

ERROR: Installation Aborted, message: Bundler could not find compatible versions for gem "logstash-core-plugin-api":

Which then tells me to try a bundle install resulting in this error.


(system) #2

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.