Logstash-output-mongodb


(Nikhil Chandrakant Parab) #1

Not able to install output plugin for logstash 5.6.2 version.
giving following error

Plugin version conflict, aborting
ERROR: Installation Aborted, message: Bundler could not find compatible versions for gem "mongo":
In snapshot (Gemfile.lock):
mongo (= 2.4.3)

In Gemfile:
logstash-input-mongodb (>= 0) java depends on
mongo (>= 2.0.0) java

logstash-output-mongodb (>= 0) java depends on
  mongo (~> 2.0.6) java

Running bundle update will rebuild your snapshot from scratch, using only
the gems in your Gemfile, which may resolve the conflict.
Bundler could not find compatible versions for gem "logstash-core":
In snapshot (Gemfile.lock):
logstash-core (= 5.6.2)

In Gemfile:
logstash-core-plugin-api (>= 0) java depends on
logstash-core (= 5.6.2) java

logstash-input-mongodb (>= 0) java depends on
  logstash-core (>= 5.0) java

logstash-output-mongodb (>= 0) java depends on
  logstash-core (< 2.0.0, >= 1.4.0) java

logstash-core (>= 0) java

Running bundle update will rebuild your snapshot from scratch, using only
the gems in your Gemfile, which may resolve the conflict.
Bundler could not find compatible versions for gem "logstash":
In Gemfile:
logstash-output-mongodb (>= 0) java depends on
logstash (< 2.0.0, >= 1.4.0) java
Could not find gem 'logstash (< 2.0.0, >= 1.4.0) java', which is required by gem 'logstash-output-mongodb (>= 0) java', in any of the sources.

can anybody pls reply for this???


(system) #2

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.