CA location configuration missing for ElasticSearch output


(Owulff) #1

Hi there
In logstash-forwarder you could configure the location of the CA in the configuration. I've run some tests with topbeat and noticed that you have to rely on the OS settings to establish an SSL connection which is described here:
https://www.elastic.co/guide/en/beats/packetbeat/current/_using_https_and_basic_authentication.html

I'd appreciate if you could configure for both outputs (es and lumberjack) the option to configure the custom CA specifically?
Thanks
Oli


(Steffen Siering) #2

Yes, there is currently a very annoying feature disparity.

You can follow progress on this here: https://github.com/elastic/libbeat/issues/79

Thanks!


(system) #3