Call command "curator_cli --help" get error message


(Little Five) #1
[root@FTJF-ELK-TEST ~]# curator --help
Traceback (most recent call last):
  File "/usr/local/python2.7/bin/curator", line 7, in <module>
    from curator.cli import cli
  File "/usr/local/python2.7/lib/python2.7/site-packages/curator/__init__.py", line 6, in <module>
    from .utils import *
  File "/usr/local/python2.7/lib/python2.7/site-packages/curator/utils.py", line 1, in <module>
    import elasticsearch
  File "/usr/local/python2.7/lib/python2.7/site-packages/elasticsearch/__init__.py", line 17, in <module>
    from .client import Elasticsearch
  File "/usr/local/python2.7/lib/python2.7/site-packages/elasticsearch/client/__init__.py", line 4, in <module>
    from ..transport import Transport
  File "/usr/local/python2.7/lib/python2.7/site-packages/elasticsearch/transport.py", line 4, in <module>
    from .connection import Urllib3HttpConnection
  File "/usr/local/python2.7/lib/python2.7/site-packages/elasticsearch/connection/__init__.py", line 3, in <module>
    from .http_urllib3 import Urllib3HttpConnection, create_ssl_context
  File "/usr/local/python2.7/lib/python2.7/site-packages/elasticsearch/connection/http_urllib3.py", line 2, in <module>
    import ssl
  File "/usr/local/python2.7/lib/python2.7/ssl.py", line 98, in <module>
    import _ssl             # if we can't import it, let the error propagate

(Aaron Mildenstein) #2

I'm guessing that you have a much older version of Python 2.7, and it does not have the appropriate SSL libraries.

Have you considered installing one of the RPM or DEB packages (if this is a linux box)? These pre-packaged versions come with their own version of Python 3.6, and are fully up-to-date.

If it's some other unix-like system (FreeBSD, etc) that cannot use DEB/RPM packages, have please consider installing Python 3.5 or better still, 3.6. Older versions of Python 2.7 may simply not have the correct SSL libraries/modules installed. Curator is tested with the latest versions of Python 2.7, 3.5, and 3.6. Older than 2.7.10 or 2.7.11 may be in need of an update.


(Little Five) #3

After I upgraded my python to 3.6, the problem was solved. Thank you very much for you help!


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.