Calling metricbeat Makefile issues

I am new to ealsticsearch and metricbeat, and GO/MAGE. I've successfully compiled filebeat and am working on metricbeat on a Power9 ppc64le system. The following make commands work successfully:

make check
make fmt

When I issue the make build command, the message states "there is nothing to be done". Other targets states that there are no rule to make target.

And when I issue the make command with no targets, it returns the following.

[root@r1cn07 metricbeat]# pwd
/root/bld/beats/src/github.com/elastic/beats/metricbeat
[root@r1cn07 metricbeat]# make
Use mage rather than make. Here are the available mage targets:
Targets:
  addLicenseHeaders                 adds license headers
  build                             builds the Beat binary.
  buildGoDaemon                     builds the go-daemon binary (use crossBuildGoDaemon).
  check                             formats code, updates generated content, check for common errors, and checks for any modified files.
  checkLicenseHeaders               checks license headers
  clean                             cleans all generated files and build artifacts.
  collectAll                        generates the docs and the fields.

I've been searching for documentation that will help me build metricbeat on ppc64le, and a little more info on how to execute the Makefiles and the format for parameters. I could use some help with this.
Thanks.

@ruhlowr,

Try running mage package.
I would strongly recommend you use the PLATFORMS environment variable to constrain the build targets. For example: export PLATFORMS=linux

Thanks Alex, I set PLATFORMS to linux and issued the mage package, but that tried to compile linux/x86, linux/arm64, and linux/amd64, and failed. I then executed "mage build" and that worked.