Cannot add _timestamp post indexing


(Shaunak Kashyap) #1

PROBLEM

I have documents already indexed in Elasticsearch. I recently discovered that I forgot to enable the _timestamp metadata field. I tried using the mapping API to update the existing mapping for my type but the store:true change does not get applied.

{ 
  "_timestamp" : { 
  "enabled" : "true", 
  "store" : "true" 
} 

CAUSE

The behavior observed is expected as currently designed. The store parameter on an existing field cannot be updated once the data has been indexed. This applies to the _timestamp field as well.

SOLUTION

Re-index and set "enabled": "true" and "store": "true" for the _timestamp metadata field prior to indexing data.


(system) #2