Problems with timestamp field feature


(Thiago Souza) #1

Hi,

Is the _timestamp field supposed to show up in documents if enabled

(with store=true)?

If so, I can't get it to work. I've setup default-mapping.json to:

{ "default" : {
"_timestamp": {
"enabled": true,
"store": true,
"index": "analyzed"
}
}}

When indexing (through java)

"setTimestamp(String.valueOf(System.currentTimeMillis()))" is called. But
when doing a simple search (_search/q=:) the "_timestamp" field won't
show up. Any clue anyone?

Cheers,
Thiago Souza


(Clinton Gormley) #2

Hi Thiago

Is the _timestamp field supposed to show up in documents if

enabled (with store=true)?

you have to explicitly request it with fields=['_timestamp','_source']

clint

If so, I can't get it to work. I've setup default-mapping.json to:

{ "default" : {
"_timestamp": {
"enabled": true,
"store": true,
"index": "analyzed"
}
}}

When indexing (through java)

"setTimestamp(String.valueOf(System.currentTimeMillis()))" is called.
But when doing a simple search (_search/q=:) the "_timestamp" field
won't show up. Any clue anyone?

Cheers,
Thiago Souza


(Thiago Souza) #3

Hi,

 Got it! Thanks!!!

Cheers

On Tue, Jul 24, 2012 at 12:39 PM, Clinton Gormley clint@traveljury.comwrote:

Hi Thiago

Is the _timestamp field supposed to show up in documents if

enabled (with store=true)?

you have to explicitly request it with fields=['_timestamp','_source']

clint

If so, I can't get it to work. I've setup default-mapping.json to:

{ "default" : {
"_timestamp": {
"enabled": true,
"store": true,
"index": "analyzed"
}
}}

When indexing (through java)

"setTimestamp(String.valueOf(System.currentTimeMillis()))" is called.
But when doing a simple search (_search/q=:) the "_timestamp" field
won't show up. Any clue anyone?

Cheers,
Thiago Souza


(system) #4