Cannot connect to remote cluster in proxy mode

Hi, I'm trying to add remote cluster through the PUT _cluster/settings, and was able to successfully add one.

  {
    "acknowledged": true,
    "persistent": {
        "cluster": {
            "remote": {
                "anothercluster": {
                    "mode": "proxy",
                    "skip_unavailable": "false",
                    "proxy_socket_connections": "18",
                    "proxy_address": "anothercluster:9300"
                }
            }
        }
    },
    "transient": {}
  }

That said, when I actually do GET _remote/info, it just returns {}, and cannot do any CCS related stuff.

I think I've followed all steps documented here https://www.elastic.co/guide/en/elasticsearch/reference/current/modules-remote-clusters.html, but can't figure out what's wrong with the setup.

Both clusters are running 7.9.1 and xpack.security.enabled: false, so no SSL related issue there.

I think this is inline with what @Sebastian_Treu saw in his thread Remote cluster connected but not listed. Not sure how he solved the issue.

Any help would be appreciated.