Cannot Create a keystore in elasticsearch 5.6.5


(shwan@derepower.com) #1

Hello,
I'm following the documentation on the official website of elastic. However, it gives me this error:
ERROR: String value must contain only ASCII
the steps i'm doing are the following:
bin/elasticsearch-keystore create
cat /etc/elasticsearch/elasticsearch.keystore | bin/elasticsearch-keystore add --stdin the.setting.name.to.set
P.S /etc/elasticsearch/elasticsearch.keystore the created file by the elasticsearch-keystore and its value inside is not ASCII
"�00=0!0sear+�+�6'�sR{ѣY��#���!Ƹ�K\�hC�`���@�g&�(��M�G"


(David Pilato) #2

cat /etc/elasticsearch/elasticsearch.keystore is wrong I believe. Why are you doing that?


(shwan@derepower.com) #3

@dadoonet in the documentation it says
cat /file/containing/setting/value | bin/elasticsearch-keystore add --stdin the.setting.name.to.set


(David Pilato) #4

Does /etc/elasticsearch/elasticsearch.keystore contains a value?


(shwan@derepower.com) #5

yes something like this
�00=0!0sear+�+�6'�sR{ѣY��#���!Ƹ�K\�hC�`���@�g&�(��M�G
generated by the first command


(David Pilato) #6

It's not a value. It's the keystore itself.

What are you trying to do? Which settings you want to add to the keystore?


(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.