Cannot see filebeat dashboards in kibana after installing and configuring them as per docs


(Sherri Conrod) #1

Hi I would greatly appreciate some help:0) I have installed filebeat, created the index, and I am receiving data to the index successfully. I have configured kibana to load the filebeat dashboards yet I am not seeing them when I log into kibana. I have restarted both kibana and filebeat services.

Error:

2018-01-08T10:34:09-08:00 INFO For Elasticsearch version >= 6.0.0, the Kibana dashboards need to be imported via the Kibana API.
2018-01-08T10:34:09-08:00 CRIT Exiting: Error importing Kibana dashboards: fail to create the Kibana loader: Error creating Kibana client: can not convert 'object' into 'string' accessing 'setup.kibana.host' (source:'/etc/filebeat/filebeat.yml')

I have followed all steps here:
https://www.elastic.co/guide/en/beats/filebeat/current/configuration-dashboards.html

I can see the dashboards listed here:
/usr/share/filebeat/kibana/default/dashboard# ls -la
total 172
drwxr-xr-x 2 root root 4096 Dec 21 15:37 .
drwxr-xr-x 4 root root 4096 Dec 21 15:37 ..
-rw-r--r-- 1 root root 14087 Nov 10 10:27 Filebeat-apache2.json
-rw-r--r-- 1 root root 9416 Nov 10 10:27 Filebeat-auditd.json
-rw-r--r-- 1 root root 7988 Nov 10 10:27 Filebeat-auth-sudo-commands.json
-rw-r--r-- 1 root root 6053 Nov 10 10:27 Filebeat-icinga-debug-log.json
-rw-r--r-- 1 root root 5973 Nov 10 10:27 Filebeat-icinga-main-log.json
-rw-r--r-- 1 root root 3384 Nov 10 10:27 Filebeat-icinga-startup-errors.json
-rw-r--r-- 1 root root 11818 Nov 10 10:27 Filebeat-mysql.json
-rw-r--r-- 1 root root 15440 Nov 10 10:27 Filebeat-new-users-and-groups.json
-rw-r--r-- 1 root root 15167 Nov 10 10:27 Filebeat-nginx-overview.json
-rw-r--r-- 1 root root 9512 Nov 10 10:27 Filebeat-redis.json
-rw-r--r-- 1 root root 10877 Nov 10 10:27 Filebeat-ssh-login-attempts.json
-rw-r--r-- 1 root root 6270 Nov 10 10:27 Filebeat-syslog.json
-rw-r--r-- 1 root root 12571 Nov 10 10:27 ml-nginx-access-remote-ip-count-explorer.json
-rw-r--r-- 1 root root 12595 Nov 10 10:27 ml-nginx-remote-ip-url-explorer.json
root@ubuntu-16:/usr/share/filebeat/kibana/default/dashboard#


Here is the config I have added to the filebeat.yml file to send the filebeat data to elasticsearch:

filebeat.prospectors:

# Each - is a prospector. Most options can be set at the prospector level, so
# you can use different prospectors for various configurations.
# Below are the prospector specific configurations.

- type: log

  # Change to true to enable this prospector configuration.
  enabled: true

  # Paths that should be crawled and fetched. Glob based paths.
filebeat.prospectors:
- type: log
  enabled: true
  paths:
    - /opt/sample-data/E1-logs-v1/*.log
exclude_lines: ['^      0       1       2       3']

====Dashboards=======
setup.dashboards.enabled: true
setup.template.enabled: true

#============================== Kibana =====================================

# Starting with Beats version 6.0.0, the dashboards are loaded via the Kibana API.
# This requires a Kibana endpoint configuration.
setup.kibana:

  # Kibana Host
  # Scheme and port can be left out and will be set to the default (http and 5601)
  # In case you specify and additional path, the scheme is required: http://localhost:5601/path
  # IPv6 addresses should always be defined as: https://[2001:db8::1]:5601
  host: "10.0.2.15:5601"


(Steffen Siering) #2

This looks like a problem with parsing your config file. Can you post the complete config file please?

Please format your config file with the </>-Button, so to preserve indentation special symbols. I'm not sure your original posts config is correctly presented.

If the problem persists, the output of running filebeat with -v -e -d '*,config' would be interesting.


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.