Cannot start elastic search server

I downloaded elasticsearch-7.13.1-windows-x86_64.zip, but when I run elasticsearch-service-x64.exe it immediately crashes briefly flashing a blank window. If I run elasticsearch.bat, it gets the following exception.

uncaught exception in thread [main]
ElasticsearchException[X-Pack is not supported and Machine Learning is not avail
able for [windows-x86]; you can use the other X-Pack features (unsupported) by s
etting xpack.ml.enabled: false in elasticsearch.yml]
at org.elasticsearch.xpack.ml.MachineLearningFeatureSet.isRunningOnMlPla
tform(MachineLearningFeatureSet.java:127)
at org.elasticsearch.xpack.ml.MachineLearningFeatureSet.isRunningOnMlPla
tform(MachineLearningFeatureSet.java:118)
at org.elasticsearch.xpack.ml.MachineLearning.createComponents(MachineLe
arning.java:693)
at org.elasticsearch.node.Node.lambda$new$18(Node.java:605)
at java.util.stream.ReferencePipeline$7$1.accept(ReferencePipeline.java:
267)
at java.util.ArrayList$ArrayListSpliterator.forEachRemaining(ArrayList.j
ava:1382)
at java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:481)

    at java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.ja

va:471)
at java.util.stream.ReduceOps$ReduceOp.evaluateSequential(ReduceOps.java
:708)
at java.util.stream.AbstractPipeline.evaluate(AbstractPipeline.java:234)

    at java.util.stream.ReferencePipeline.collect(ReferencePipeline.java:499

)
at org.elasticsearch.node.Node.(Node.java:609)
at org.elasticsearch.node.Node.(Node.java:278)
at org.elasticsearch.bootstrap.Bootstrap$5.(Bootstrap.java:217)
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:217)
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:397)
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:159
)
at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:
150)
at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwar
eCommand.java:75)
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:1
16)
at org.elasticsearch.cli.Command.main(Command.java:79)
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:115
)
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:81)

For complete error details, refer to the log at D:\Code2\elasticsearch-7.13.1\lo
gs\elasticsearch.log

Below is the tail end of my elasticsearch.log file.

[2021-06-10T21:25:40,346][INFO ][o.e.e.NodeEnvironment ] [MYDEVICE] heap size [989.8mb], compressed ordinary object pointers [unknown]
[2021-06-10T21:25:40,490][INFO ][o.e.n.Node ] [MYDEVICE] node name [MYDEVICE], node ID [4Prub7efReSNXdYQ_OG0Mg], cluster name [elasticsearch], roles [transform, data_frozen, master, remote_cluster_client, data, ml, data_content, data_hot, data_warm, data_cold, ingest]
[2021-06-10T21:25:44,379][ERROR][o.e.b.Bootstrap ] [MYDEVICE] Exception
org.elasticsearch.ElasticsearchException: X-Pack is not supported and Machine Learning is not available for [windows-x86]; you can use the other X-Pack features (unsupported) by setting xpack.ml.enabled: false in elasticsearch.yml
at org.elasticsearch.xpack.ml.MachineLearningFeatureSet.isRunningOnMlPlatform(MachineLearningFeatureSet.java:127) ~[?:?]
at org.elasticsearch.xpack.ml.MachineLearningFeatureSet.isRunningOnMlPlatform(MachineLearningFeatureSet.java:118) ~[?:?]
at org.elasticsearch.xpack.ml.MachineLearning.createComponents(MachineLearning.java:693) ~[?:?]
at org.elasticsearch.node.Node.lambda$new$18(Node.java:605) ~[elasticsearch-7.13.1.jar:7.13.1]
at java.util.stream.ReferencePipeline$7$1.accept(ReferencePipeline.java:267) ~[?:1.8.0_161]
at java.util.ArrayList$ArrayListSpliterator.forEachRemaining(ArrayList.java:1382) ~[?:1.8.0_161]
at java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:481) ~[?:1.8.0_161]
at java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.java:471) ~[?:1.8.0_161]
at java.util.stream.ReduceOps$ReduceOp.evaluateSequential(ReduceOps.java:708) ~[?:1.8.0_161]
at java.util.stream.AbstractPipeline.evaluate(AbstractPipeline.java:234) ~[?:1.8.0_161]
at java.util.stream.ReferencePipeline.collect(ReferencePipeline.java:499) ~[?:1.8.0_161]
at org.elasticsearch.node.Node.(Node.java:609) ~[elasticsearch-7.13.1.jar:7.13.1]
at org.elasticsearch.node.Node.(Node.java:278) ~[elasticsearch-7.13.1.jar:7.13.1]
at org.elasticsearch.bootstrap.Bootstrap$5.(Bootstrap.java:217) ~[elasticsearch-7.13.1.jar:7.13.1]
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:217) ~[elasticsearch-7.13.1.jar:7.13.1]
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:397) [elasticsearch-7.13.1.jar:7.13.1]
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:159) [elasticsearch-7.13.1.jar:7.13.1]
at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:150) [elasticsearch-7.13.1.jar:7.13.1]
at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:75) [elasticsearch-7.13.1.jar:7.13.1]
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:116) [elasticsearch-cli-7.13.1.jar:7.13.1]
at org.elasticsearch.cli.Command.main(Command.java:79) [elasticsearch-cli-7.13.1.jar:7.13.1]
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:115) [elasticsearch-7.13.1.jar:7.13.1]
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:81) [elasticsearch-7.13.1.jar:7.13.1]
[2021-06-10T21:25:44,380][ERROR][o.e.b.ElasticsearchUncaughtExceptionHandler] [MYDEVICE] uncaught exception in thread [main]
org.elasticsearch.bootstrap.StartupException: ElasticsearchException[X-Pack is not supported and Machine Learning is not available for [windows-x86]; you can use the other X-Pack features (unsupported) by setting xpack.ml.enabled: false in elasticsearch.yml]
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:163) ~[elasticsearch-7.13.1.jar:7.13.1]
at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:150) ~[elasticsearch-7.13.1.jar:7.13.1]
at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:75) ~[elasticsearch-7.13.1.jar:7.13.1]
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:116) ~[elasticsearch-cli-7.13.1.jar:7.13.1]
at org.elasticsearch.cli.Command.main(Command.java:79) ~[elasticsearch-cli-7.13.1.jar:7.13.1]
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:115) ~[elasticsearch-7.13.1.jar:7.13.1]
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:81) ~[elasticsearch-7.13.1.jar:7.13.1]
Caused by: org.elasticsearch.ElasticsearchException: X-Pack is not supported and Machine Learning is not available for [windows-x86]; you can use the other X-Pack features (unsupported) by setting xpack.ml.enabled: false in elasticsearch.yml
at org.elasticsearch.xpack.ml.MachineLearningFeatureSet.isRunningOnMlPlatform(MachineLearningFeatureSet.java:127) ~[?:?]
at org.elasticsearch.xpack.ml.MachineLearningFeatureSet.isRunningOnMlPlatform(MachineLearningFeatureSet.java:118) ~[?:?]
at org.elasticsearch.xpack.ml.MachineLearning.createComponents(MachineLearning.java:693) ~[?:?]
at org.elasticsearch.node.Node.lambda$new$18(Node.java:605) ~[elasticsearch-7.13.1.jar:7.13.1]
at java.util.stream.ReferencePipeline$7$1.accept(ReferencePipeline.java:267) ~[?:1.8.0_161]
at java.util.ArrayList$ArrayListSpliterator.forEachRemaining(ArrayList.java:1382) ~[?:1.8.0_161]
at java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:481) ~[?:1.8.0_161]
at java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.java:471) ~[?:1.8.0_161]
at java.util.stream.ReduceOps$ReduceOp.evaluateSequential(ReduceOps.java:708) ~[?:1.8.0_161]
at java.util.stream.AbstractPipeline.evaluate(AbstractPipeline.java:234) ~[?:1.8.0_161]
at java.util.stream.ReferencePipeline.collect(ReferencePipeline.java:499) ~[?:1.8.0_161]
at org.elasticsearch.node.Node.(Node.java:609) ~[elasticsearch-7.13.1.jar:7.13.1]
at org.elasticsearch.node.Node.(Node.java:278) ~[elasticsearch-7.13.1.jar:7.13.1]
at org.elasticsearch.bootstrap.Bootstrap$5.(Bootstrap.java:217) ~[elasticsearch-7.13.1.jar:7.13.1]
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:217) ~[elasticsearch-7.13.1.jar:7.13.1]
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:397) ~[elasticsearch-7.13.1.jar:7.13.1]
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:159) ~[elasticsearch-7.13.1.jar:7.13.1]
... 6 more

Looks like the reason is that you have a 32-bit OS, which I do not think is supported.