Elasticsearch wont start with X-Pack plug-in on Windows


I'm tyring to configure X-Pack in Elasticsearch 6.2.2 on Windows x86 64 bit and I'm following these instructions: https://www.elastic.co/guide/en/elasticsearch/reference/6.2/installing-xpack-es.html At step 6, when I run elasticsearch.bat, I get the following exception:

uncaught exception in thread [main]
org.elasticsearch.bootstrap.StartupException: ElasticsearchException[X-Pack is n
ot supported and Machine Learning is not available for [windows-x86]; you can us
e the other X-Pack features (unsupported) by setting xpack.ml.enabled: false in

I then set xpack.ml.enabled: false in elasticsearch.yml and ran elasticsearch.bat again. Unfortunately, I keep getting the same exception and Elasticsearch won't start.

Can someone please help me?




Most likely you are running a 32bit JVM so Elasticsearch considers your machine to be 32 bit architecture which is incompatible with Machine Learning.

If I run the command java --version on macos the output is

 java 9.0.1
 Java(TM) SE Runtime Environment (build 9.0.1+11)
 Java HotSpot(TM) 64-Bit Server VM (build 9.0.1+11, mixed mode)

Can you install a 64bit JVM on your machine, you should be using Java 8 or 9 if you are using a recent release.

Take a look at the supported JVMs: https://www.elastic.co/support/matrix#matrix_jvm

My guess is that the elasticsearch.yml file you're editing isn't the one Elasticsearch is reading from.
Do you have a ES_PATH_CONF environment variable?

1 Like

Hi David,

Thank you for responding. I have a 32-bit machine (as you can see below).
Shouldn't setting xpack.ml.enabled: false in elasticsearch.yml bypass this


C:\Users\crosbyh>java -version
Picked up _JAVA_OPTIONS: -Xmx512M -Xms256M
java version "1.8.0_111"
Java(TM) SE Runtime Environment (build 1.8.0_111-b14)
Java HotSpot(TM) Client VM (build 25.111-b14, mixed mode)

C:\Users\crosbyh>java -d64 - version
Error: This Java instance does not support a 64-bit JVM.
Please install the desired version.

Hi Tim,

Setting ES_PATH_CONF resolved the issue and I can now move on to step 7 of
installing X-Pack on Elasticsearch. :slight_smile:



This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.