Cannot start ElasticSearch


#1

We have previously set up ELKStack and it has worked without error for several weeks but since yesterday we cannot start ElasticSearch. Logstash, Filebeat and Kibana works like they should.

But when we try to start ES we get an instant error saying "\Common was unexpected at this time." in the cmd prompt.

We have not made any conscious changes to any part of the configuration and we suspect a Windows update is to blame.

Could this be it and if so, what should we do to fix it?


(Mark Walkom) #2

Please share the command you are running, the output it provides, any logs and the version you are running.


#3

Running ES 6.2.2

trying to launch the elasticsearch.bat file gives us this:

C:\Users\testuser\Desktop\ElasticSearch\elasticsearch-6.2.2\bin>elasticsearch

\Common was unexpected at this time.

We do not get any logs.

Issue persists on different users with copies of the same config.


#4

It was the latest Java update that caused the issue. Reverted to older version and it worked, hope for a fix.


Windows Install Newbie- Installing Elasticsearch using Zip
(Mark Walkom) #5

What version did you upgrade to and from>


#6

We ran it on Java 8 Update 161 and updated to 171, which didn't work, so we reverted to 161.


(teoman shipahi) #7

I am having same issue on WinServer 2016.
JAVA_HOME=C:\Program Files\Java\jdk-10.0.1


(Mark Walkom) #8

We don't support Java 10 at this stage.


(Tom Reynaert) #9

Hi,
I had the same issue today, but for me it wasnt really caused by the Java version.
In my PATH environment variable on windows i had something like "C:\Program Files (x86)\Common Files\Oracle\Java\javapath" to point to the java version.
After replacing this with the direct path to the JRE bin directory, it started fine for me even with Java 8u172.

Grts,

Tom


(Ryan O'Connor) #10

Thanks Tom, I had the same problem after updating to Java 8 r171. I had the same path in my system environment variables, but found java.exe in my windows folder. So I simply deleted C:\Program Files (x86)\Common Files\Oracle\Java\javapath from my PATH and elasticsearch fires up now.

Annoyingly I arrived at this situation because I didn't have a recent enough version of Java for elastic search initially!


(system) #11

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.