Cannot start logstash using bin\logstash.bat -f logstash-lab.conf -r

I am a newbie. I am trying to be as clear as I can.
A team member recently attended elastic conference and brought back a zipped folder containing some training material and elastic stack 5.2.0. I am trying to follow the Lab Guide that gets you up and running.
Lab 1: running the elastic search, done without error. Also started metricbeat and kibana without error.
Lab 2: Unzipped filebeat-windows-x86_64, modified filebeat.yml to include path to logs folder as instructed in the training material, then I run filebeat.exe -configtest and it says Config OK. Then I run filebeat.exe and it seems to be running, in a new terminal
Lab 3: I go to logstash subdirectory and create a file logstash-lab.conf per instruction, the following is what this file contains

input {
beats {
host => "localhost"
port => 5044
}
}

filter {}

output {
stdout {
codec => rubydebug
}
}

Next I run bin\logstash.bat -f logstash-lab.conf -r per instruction, and this is where I see the following error.

[2017-03-30T11:46:54,545][ERROR][logstash.plugins.registry] Problems loading a plugin with {:type=>"input", :name=>"beats", :path=>"logstash/inputs/beats", :error_message=>"\n\n\tyou might need to reinstall the gem which depends on the missing jar or in case there is Jars.lock then resolve the jars with lock_jars command\n\nno such file to load -- io/netty/netty-tcnative-boringssl-static/1.1.33.Fork23/netty-tcnative-boringssl-static-1.1.33.Fork23 (LoadError)", :error_class=>RuntimeError, :error_backtrace=>["C:/Users/siqbal/Documents/elastic-stack-workshop-5.2.0/elastic-stack-workshop/logstash/vendor/bundle/jruby/1.9/gems/jar-dependencies-0.3.10/lib/jar_dependencies.rb:348:in do_require'", "C:/Users/siqbal/Documents/elastic-stack-workshop-5.2.0/elastic-stack-workshop/logstash/vendor/bundle/jruby/1.9/gems/jar-dependencies-0.3.10/lib/jar_dependencies.rb:255:inrequire_jar'", "C:/Users/siqbal/Documents/elastic-stack-workshop-5.2.0/elastic-stack-workshop/logstash/vendor/bundle/jruby/1.9/gems/jar-dependencies-0.3.10/lib/jar_dependencies.rb:0:in require_jar_with_block'", "C:/Users/siqbal/Documents/elastic-stack-workshop-5.2.0/elastic-stack-workshop/logstash/vendor/bundle/jruby/1.9/gems/jar-dependencies-0.3.10/lib/jar_dependencies.rb:254:inrequire_jar'", "C:/Users/siqbal/Documents/elastic-stack-workshop-5.2.0/elastic-stack-workshop/logstash/lib/bootstrap/patches/jar_dependencies.rb:6:in require_jar'", "C:/Users/siqbal/Documents/elastic-stack-workshop-5.2.0/elastic-stack-workshop/logstash/vendor/bundle/jruby/1.9/gems/logstash-input-beats-3.1.12-java/lib/logstash-input-beats_jars.rb:5:in(root)'", "org/jruby/RubyKernel.java:1040:in require'", "C:/Users/siqbal/Documents/elastic-stack-workshop-5.2.0/elastic-stack-workshop/logstash/vendor/bundle/jruby/1.9/gems/polyglot-0.3.5/lib/polyglot.rb:65:inrequire'", "C:/Users/siqbal/Documents/elastic-stack-workshop-5.2.0/elastic-stack-workshop/logstash/vendor/bundle/jruby/1.9/gems/logstash-input-beats-3.1.12-java/lib/logstash/inputs/beats.rb:1:in (root)'", "org/jruby/RubyKernel.java:1040:inrequire'", "C:/Users/siqbal/Documents/elastic-stack-workshop-5.2.0/elastic-stack-workshop/logstash/vendor/bundle/jruby/1.9/gems/polyglot-0.3.5/lib/polyglot.rb:65:in require'", "C:/Users/siqbal/Documents/elastic-stack-workshop-5.2.0/elastic-stack-workshop/logstash/vendor/bundle/jruby/1.9/gems/logstash-input-beats-3.1.12-java/lib/logstash/inputs/beats.rb:8:in(root)'", "C:/Users/siqbal/Documents/elastic-stack-workshop-5.2.0/elastic-stack-workshop/logstash/logstash-core/lib/logstash/plugins/registry.rb:1:in (root)'", "C:/Users/siqbal/Documents/elastic-stack-workshop-5.2.0/elastic-stack-workshop/logstash/logstash-core/lib/logstash/plugins/registry.rb:151:inlegacy_lookup'", "C:/Users/siqbal/Documents/elastic-stack-workshop-5.2.0/elastic-stack-workshop/logstash/logstash-core/lib/logstash/plugins/registry.rb:133:in lookup'", "C:/Users/siqbal/Documents/elastic-stack-workshop-5.2.0/elastic-stack-workshop/logstash/logstash-core/lib/logstash/plugins/registry.rb:175:inlookup_pipeline_plugin'", "C:/Users/siqbal/Documents/elastic-stack-workshop-5.2.0/elastic-stack-workshop/logstash/logstash-core/lib/logstash/plugin.rb:129:in lookup'", "org/jruby/RubyKernel.java:1079:ineval'", "C:/Users/siqbal/Documents/elastic-stack-workshop-5.2.0/elastic-stack-workshop/logstash/logstash-core/lib/logstash/pipeline.rb:452:in plugin'", "(eval):8:ininitialize'", "C:/Users/siqbal/Documents/elastic-stack-workshop-5.2.0/elastic-stack-workshop/logstash/logstash-core/lib/logstash/pipeline.rb:98:in initialize'", "C:/Users/siqbal/Documents/elastic-stack-workshop-5.2.0/elastic-stack-workshop/logstash/logstash-core/lib/logstash/agent.rb:246:increate_pipeline'", "C:/Users/siqbal/Documents/elastic-stack-workshop-5.2.0/elastic-stack-workshop/logstash/logstash-core/lib/logstash/agent.rb:95:in register_pipeline'", "C:/Users/siqbal/Documents/elastic-stack-workshop-5.2.0/elastic-stack-workshop/logstash/logstash-core/lib/logstash/runner.rb:264:inexecute'", "C:/Users/siqbal/Documents/elastic-stack-workshop-5.2.0/elastic-stack-workshop/logstash/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/command.rb:67:in run'", "C:\\Users\\siqbal\\Documents\\elastic-stack-workshop-5.2.0\\elastic-stack-workshop\\logstash\\lib\\bootstrap\\environment.rb:71:in(root)'"]}
[2017-03-30T11:46:54,612][ERROR][logstash.agent ] fetched an invalid config {:config=>"input {\n beats {\n host => "localhost"\n port => 5044\n }\n}\n\nfilter {}\n\noutput { \n stdout {\n codec => rubydebug\n }\n}\n", :reason=>"Couldn't find any input plugin named 'beats'. Are you sure this is correct? Trying to load the beats input plugin resulted in this error: Problems loading the requested plugin named beats of type input. Error: RuntimeError \n\n\tyou might need to reinstall the gem which depends on the missing jar or in case there is Jars.lock then resolve the jars with lock_jars command\n\nno such file to load -- io/netty/netty-tcnative-boringssl-static/1.1.33.Fork23/netty-tcnative-boringssl-static-1.1.33.Fork23 (LoadError)"}

whereas according to training material, the expected output in the terminal should be similar to the following(some lines excised to stay within character limit for post), which obviously it is not.

[2016-10-13T14:03:01,935][INFO ][logstash.inputs.beats ] Beats inputs: Starting input listener {:address=>"localhost:5044"}
[2016-10-13T14:03:02,361][INFO ][logstash.pipeline ] Starting pipeline {"id"=>"main", "pipeline.workers"=>4,
[2016-10-13T14:03:02,451][INFO ][logstash.agent ] Successfully started Logstash API endpoint {:port=>9600}

I am stuck at this point. My teammate didn't get this error when he tried on his MacBook, but I am on Windows 7. I will appreciate some guidance here. Thank you in advance.

What is your JVM version?

Java 1.8.0_101
JAVA_HOME is is also set to this version.

I installed Java 8 and set JAVA_HOME to where it is located. java -version
does indeed show jdk 8

Thanks for asking.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.