Cant add _size to mapping in elasticsearch 5.5


(sami) #1

[root@hadoop1 ~]# curl -XPUT 'hadoop5:9200/lanetxn/txn_details/_mapping?pretty' -d '

{
"mappings": {
"txn_dtails": {
"_size": {
"enabled": true
}
}
}
}
'
{
"error" : {
"root_cause" : [
{
"type" : "mapper_parsing_exception",
"reason" : "Root mapping definition has unsupported parameters: [mappings : {txn_dtails={_size={enabled=true}}}]"
}
],
"type" : "mapper_parsing_exception",
"reason" : "Root mapping definition has unsupported parameters: [mappings : {txn_dtails={_size={enabled=true}}}]"
},
"status" : 400
}


(Zachary Tong) #2

That functionality was moved to a plugin in 2.x: https://www.elastic.co/guide/en/elasticsearch/plugins/current/mapper-size.html


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.