Elaspic mapper-size not working


(sami) #1

I have installed the mapper-size plugin on all cluster nodes and rebooted the server but still I cant modify the mapping , please advise .

[elasticsearch@hadoop1 bin]$ ./elasticsearch-plugin install mapper-size
-> Downloading mapper-size from elastic
[=================================================] 100%
-> Installed mapper-size

[elasticsearch@hadoop2 bin]$ curl -XPUT 'hadoop5:9200/lanetxn/_mapping/txn_details?pretty' -d '

{
"properties":{
"_size": {
"enabled": true
}
}
}'
{
"error" : {
"root_cause" : [
{
"type" : "remote_transport_exception",
"reason" : "[hadoop1][10.100.44.17:9300][indices:admin/mapping/put]"
}
],
"type" : "illegal_argument_exception",
"reason" : "Field [_size] is defined both as an object and a field in [txn_details]"
},
"status" : 400
}


(sami) #2

ok this syntax did the trick

curl -XPUT 'hadoop5:9200/lanetxn/_mapping/txn_details?pretty' -d '
{
"_size": {"enabled": true}
}'


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.