Can't Automatically Start Elasticsearch Service After Upgrade to 8.4.3

I can't get the Elasticsearch service to start using the Windows service on a Windows 10 machine after upgrading to 8.4.3.. I successfully used elasticsearch-service.bat to install the service and see it listed as an available Windows service when I bring up services, but if I try and start it from there I get an error stating "Error 1607: The process terminated unexpectedly".

I then tried using elastic-service.bat to start the service and that results in an error message that states "ERROR: Failed starting 'elasticsearch-service-x64' service". I see the following message in the log files when using both methods:

2022-10-22 21:40:45 Apache Commons Daemon procrun stderr initialized.
Starts and stops the Elasticsearch server process for a Windows Service

Option Description


-E Configure a setting
-h, --help Show help
-s, --silent Show minimal output
-v, --verbose Show verbose output
ERROR: quiet is not a recognized option

The weird thing is that the service starts fine if I manually run elasticsearch.bat from the elasticsearch\bin directory. Any one have any idea what the "ERROR: quiet is not a recognized option" in the log example is about and/or how I can get elastcisearch to automatically start as a service? Thanks.

Kevin

I have resolved this issue by taking the following steps but I never did figure out where the apparently errant --quiet argument was coming from. Regardless, the Elasticsearch service automatically runs now so I consider this issue resolved.

Kevin

  1. Ran the following command from the Elasticsearch bin directory to access the elasticsearch-service-x64 service properties:

elasticsearch-service manager

  1. Set Startup type to Automatic under the General tab.

  2. Removed the --quiet argument from the Arguments text filed on the Startup tab.

  3. Clicked the Apply button.

  4. Clicked Ok.

  5. Restarted my computer (Windows 10).

  6. Verified that the Elasticsearch service was running and is set to Automatic.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.