Can't Connect to Kibana via web browser


(Thomas Dasch) #1

Following this guide to learn how to setup x-pack and node TLS. I have my 2 nodes up and running and cluster health is green. The problem is I cant open Kibana in my web browser. I am attempting to connect to https://kibana.local:5601.

kibana.yml
server.name: "my-kibana"
server.host: "kibana.local"
server.ssl.enabled: true
server.ssl.certificate: /etc/kibana/config/certs/my-kibana.crt
server.ssl.key: /etc/kibana/config/certs/my-kibana.key
elasticsearch.url: "https://node1.elastic.test.com:9200"
elasticsearch.username: "kibana"
elasticsearch.password: "mypass"
elasticsearch.ssl.certificateAuthorities: [ "/etc/kibana/config/certs/ca.crt" ]

I am using Virtual Box with two Ubuntu 16.04.4 LTS VMs. ES and Kibana version 6.2.4. Networking through Vbox is NAT Network with port forwarding setup for kibana guest IP 127.0.0.01, guest port 5601. I have also tried guest IP 192.168.04(node1's IP address), guest port 5601 with no luck.

Any suggestions?


(Archana ) #2

Do you see any error output in your Kibana logs or Elasticsearch logs that you can share?


(Thomas Dasch) #3

There doesn't appear to be any problem with either node or kibana. Reading through the kibana logs I saw Jun 02 13:36:55 node1 kibana[1757]: {"type":"log","@timestamp":"2018-06-02T17:36:55Z","tags":["listening","info"],"pid":1757,"message":"Server running at https://kibana.local:5601"} which is what I am trying to connect to through my web browser.

Node1
root@node1:/var/log/elasticsearch# systemctl status elasticsearch
● elasticsearch.service - Elasticsearch
Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; disabled; vendor preset: enabled)
Active: active (running) since Sat 2018-06-02 13:26:05 EDT; 14min ago
Docs: http://www.elastic.co
Main PID: 1582 (java)
Tasks: 57
Memory: 1.3G
CPU: 3min 38.520s
CGroup: /system.slice/elasticsearch.service
├─1582 /usr/bin/java -Xms1g -Xmx1g -XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOccupancyOnly -XX:+AlwaysPreTouch -Xss1m -Djava.awt.headless=true -D
└─1634 /usr/share/elasticsearch/plugins/x-pack/x-pack-ml/platform/linux-x86_64/bin/controller

Jun 02 13:26:05 node1 systemd[1]: Started Elasticsearch.

Node 2
root@node2:/home/tdasch# systemctl status elasticsearch
● elasticsearch.service - Elasticsearch
Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; disabled; vend
Active: active (running) since Sat 2018-06-02 13:27:30 EDT; 13min ago
Docs: http://www.elastic.co
Main PID: 1499 (java)
Tasks: 52
Memory: 1.3G
CPU: 3min 1.029s
CGroup: /system.slice/elasticsearch.service
├─1499 /usr/bin/java -Xms1g -Xmx1g -XX:+UseConcMarkSweepGC -XX:CMSIni
└─1616 /usr/share/elasticsearch/plugins/x-pack/x-pack-ml/platform/lin

Jun 02 13:27:30 node2 systemd[1]: Started Elasticsearch.

Kibana
● kibana.service - Kibana
Loaded: loaded (/etc/systemd/system/kibana.service; disabled; vendor preset: enabled)
Active: active (running) since Sat 2018-06-02 13:36:21 EDT; 5min ago
Main PID: 1757 (node)
Tasks: 10
Memory: 196.7M
CPU: 39.171s
CGroup: /system.slice/kibana.service
└─1757 /usr/share/kibana/bin/../node/bin/node --no-warnings /usr/share/kibana/bin/../src/cli -c /etc/kibana/kibana.yml


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.