Can't create geo_shape multi field


(owainb) #1

Hi,

I am trying to create a mapping with a multi field where the default field
type is geo_shape and it doesn't seem to work. When I retrieve the mapping
it just appears as a normal geo_shape field. Is this a bug or is it
deliberately not possible to do this? If it's not possible, should there be
an error returned when it is attempted?

Gist: https://gist.github.com/owainb/392a5c03b89f2024fb61#file-geo_shape_multi-txt
Elasticsearch: 1.3.0
OS: Linux 32-bit
JRE: 1.7.0_65

Thanks,

Owain

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/bef54709-dacd-484a-9130-5a49e9c40ecd%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #2

IMHO it's a bug. I think you should open an issue.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 1 août 2014 à 17:29:35, Owain Braddick (owainbraddick@gmail.com) a écrit:

Hi,

I am trying to create a mapping with a multi field where the default field type is geo_shape and it doesn't seem to work. When I retrieve the mapping it just appears as a normal geo_shape field. Is this a bug or is it deliberately not possible to do this? If it's not possible, should there be an error returned when it is attempted?

Gist: https://gist.github.com/owainb/392a5c03b89f2024fb61#file-geo_shape_multi-txt
Elasticsearch: 1.3.0
OS: Linux 32-bit
JRE: 1.7.0_65

Thanks,

Owain

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/bef54709-dacd-484a-9130-5a49e9c40ecd%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.53dbb5f1.66ef438d.11c52%40MacBook-Air-de-David.local.
For more options, visit https://groups.google.com/d/optout.


(owainb) #3

Thanks David. Raised
as https://github.com/elasticsearch/elasticsearch/issues/7128.

On Friday, August 1, 2014 4:45:01 PM UTC+1, David Pilato wrote:

IMHO it's a bug. I think you should open an issue.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfr
https://twitter.com/elasticsearchfr

Le 1 août 2014 à 17:29:35, Owain Braddick (owainb...@gmail.com
<javascript:>) a écrit:

Hi,

I am trying to create a mapping with a multi field where the default field
type is geo_shape and it doesn't seem to work. When I retrieve the mapping
it just appears as a normal geo_shape field. Is this a bug or is it
deliberately not possible to do this? If it's not possible, should there be
an error returned when it is attempted?

Gist:
https://gist.github.com/owainb/392a5c03b89f2024fb61#file-geo_shape_multi-txt
Elasticsearch: 1.3.0
OS: Linux 32-bit
JRE: 1.7.0_65

Thanks,

Owain

You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/bef54709-dacd-484a-9130-5a49e9c40ecd%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/bef54709-dacd-484a-9130-5a49e9c40ecd%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/44677564-c844-4140-863f-2e41ce82266b%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #4