Cant enable metricbeat modules

[root@f7af2d4dd6a1 modules.d]# metricbeat modules enable system
Module system doesn't exist!

metricbeat modules list


[root@f7af2d4dd6a1 modules.d]# dir
aerospike.yml.disabled golang.yml.disabled kvm.yml.disabled prometheus.yml.disabled
apache.yml.disabled graphite.yml.disabled logstash.yml.disabled rabbitmq.yml.disabled
ceph.yml.disabled haproxy.yml.disabled memcached.yml.disabled redis.yml.disabled
couchbase.yml.disabled http.yml.disabled mongodb.yml.disabled system.yml
docker.yml.disabled jolokia.yml.disabled munin.yml.disabled traefik.yml.disabled
dropwizard.yml.disabled kafka.yml.disabled mysql.yml.disabled uwsgi.yml.disabled
elasticsearch.yml.disabled kibana.yml.disabled nginx.yml.disabled vsphere.yml.disabled
envoyproxy.yml.disabled kubernetes.yml.disabled php_fpm.yml.disabled windows.yml.disabled
etcd.yml.disabled kvm.yml postgresql.yml.disabled zookeeper.yml.disabled

hi @Divit_Sharma,

Thank you for reporting this!

I'm guessing you are using Metricbeat 6.4, which was released with a known issue:

6.4.1 should include the fix, in the meanwhile, there is a workaround explained in the given link

1 Like

Let me try if the workaround works

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.