Can't enroll MacOS agent

Me again..I'm trying to enroll a macOS agent and when I run the enroll command I get the following :

Error: fail to enroll: fail to execute request to fleet-server: fail to decode enrollment response: context canceled
Error: enroll command failed with exit code: 1

I've tried enrolling on multiple installs (7.14.1 and 7.14.0) with the same issue...

It seems to contact the fleet server but it leaves it in a state of updating :

Can you please provide the command you are using to enroll?

Just the one that fleet gives you when you use the add agent dialogue

for example :

sudo ./elastic-agent install -f --url=https://something.azure.elastic-cloud.com:443 --enrollment-token=secret

Another team mate gets the following on her Mac :

panic: getwd: invalid argument

goroutine 1 [running]:
github.com/elastic/beats/v7/x-pack/elastic-agent/pkg/agent/application/paths.retrieveExecutablePath(0x28, 0x0)
	/go/src/github.com/elastic/beats/x-pack/elastic-agent/pkg/agent/application/paths/common.go:157 +0x1aa
github.com/elastic/beats/v7/x-pack/elastic-agent/pkg/agent/application/paths.initialTop(0x10aa72a67, 0x10b9c9245)
	/go/src/github.com/elastic/beats/x-pack/elastic-agent/pkg/agent/application/paths/common.go:146 +0x26
github.com/elastic/beats/v7/x-pack/elastic-agent/pkg/agent/application/paths.init.0()
	/go/src/github.com/elastic/beats/x-pack/elastic-agent/pkg/agent/application/paths/common.go:36 +0x26

What OSX version ?

I second @zx8086 knowing the OSX version would be great? Also what is the execution directory you are running from? Seems that its having trouble getting its current work directory.

10.15.7 - I was running it from ~/Downloads/elastic-agent-x.y.z