Can't get past first base with Logstash

Everything fine and dandy with ELK otherwise - Filebeat, Elasticsearch, Kibana seems to work as expected.
But can't get logstash to do this first thing.

Centos 7.3 64 bit - tried installing through repository then following the instructions but the logstash systemd service doesn't open the input port - and yes I've checked the firewall.

So I decided to download the tarball and try


318 wget
319 tar xzvf logstash-5.2.1.tar.gz
320 cd logstash-5.2.1

And following:

[root@ahem logstash-5.2.1]# ls
bin data LICENSE logstash-core-queue-jruby Gemfile logstash-core NOTICE.TXT
config Gemfile.jruby-1.9.lock logstash-core-event-java vendor
CONTRIBUTORS lib logstash-core-plugin-api
[root@ahem logstash-5.2.1]# bin/logstash -e 'input { stdin { } } output { stdout {} }'

Nada. Nix. Just hangs without giving me any pipeline prompt.

Any ideas? We'd like to be able to start using ELK but not being able to begin with logstash is a bit of a hinderance.

Oh dear - perhaps I just wasn't patient enough - now I see a prompt. Very strange - it never worked before.
Consider this case closed for now.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.