ELK No Output


I really hope somebody can help me.

I have installed ELK on CentOS 6.5 and even after reinstalling onto another box using a different howto, I still can't get Logstash to send me any output. I am supposed to get Logstash to log all HTTP POST requests. Just for the sake of getting it to work I have set it up to read from the Apache log files.

I keep on getting the message:
"Waited for 30s and no initial state was set by the discovery".


Logstash 1.4.2
Elasticsearch 1.4
Kibana 4.0.0

Logstash Conf:

input {

 file {
     type => "apache"
     path => ["/var/log/apache2/access.log", "/var/log/apache2/error.log"]
    sincedb_path => "/opt/logstash/sincedb"


output {
elasticsearch {
host => localhost

 stdout {
     codec => rubydebug


Browsing to http://MyServer:9200/ :

"status" : 200,
"name" : "Grog the God-Crusher",
"cluster_name" : "elasticsearch",
"version" : {
"number" : "1.4.5",
"build_hash" : "2aaf797f2a571dcb779a3b61180afe8390ab61f9",
"build_timestamp" : "2015-04-27T08:06:06Z",
"build_snapshot" : false,
"lucene_version" : "4.10.4"
"tagline" : "You Know, for Search"

Please help!

Logstash 1.4 is ancient. Please upgrade. If you can't upgrade to Logstash 2.x or later, set protocol => "http" for the Logstash output.

This is the version we use at our company and unfortunately I can't just upgrade. I tried setting protocol => "http" but then I get this error message:

"Unknown setting 'protocol' for tcp"

I got Kibana to log Apache logs. The strange thing is that I changed the logstash config again (about 30 minutes ago) to log HTTP request and removed the apache logs from the config. But now it is still logging the apache logs instead of the HTTP requests. Is there a delay in Kibana?

I got this to work with:

input {
tcp {
port => 8081
codec => json_lines {
charset => "UTF-8"

"Unknown setting 'protocol' for tcp"

Modify the elasticsearch output, not the tcp input or output.