Logstash not binding to 5504


(Jacoblw) #1

Hi,

I'm new to the ELK stack. Following the guide for CentOS 7 created by DigitalOcean

I got as far as creating an index pattern in Kibana before I noticed I was running into an issue.

I get the following error in /var/log/logstash/logstash.log

{:timestamp=>"2015-12-14T20:14:02.545000+0000", :message=>"Connection refused", :class=>"Manticore::SocketException", :level=>:error}

The following returns nothing;

[root@elk ~]# netstat | grep 5044
[root@elk ~]# netstat | grep logstash

This is my 02-filebeat-input.conf

input {
    beats {
    port => 5044
    type => "logs"
    ssl => true
    ssl_certificate => "/etc/pki/tls/certs/logstash-forwarder.crt"
    ssl_key => "/etc/pki/tls/private/logstash-forwarder.key"
  }
}

This is my 30-elasticsearch-output.conf

output {
  elasticsearch { hosts => ["elk.systemctl.lan:9200"] }
  stdout { codec => rubydebug }
}

Host is CentOS 7, firewalld and selinux are disabled while testing.

Can anyone point me in a starting direction?

Thanks


(Magnus B├Ąck) #2

If Logstash can't bind to port 5044 there should be something about it in the log. However, since you're not including -a when invoking netstat it'll only include existing connections and not ports being listened to so it's not very surprising that you won't see anything (and the netstat output will never contain "logstash").

The message in the Logstash log file indicates that it can't connect to Elasticsearch.


(system) #3