Can't install elastic as a windows service

I'm trying to install ElasticSearch 7.7.0 on my windows server 2016 64bit.
First I downloaded the zip version, running elasticsearch.bat from CMD, everything is ok. Then I create a service using this instruction. It creates the service, but when I try to start the service, it stops immediately and I get this error:

Commons Daemon procrun stderr initialized
ERROR: the system property [es.path.conf] must be set

I set ES_PATH_CONF and ES_HOME environment variables, deleted the service, and created it again, still gives the same error.

Next, I tried the .msi version, installed it with the default configuration, it goes well and creates the service, but can't finish the job and shows failure. This happened two times. I looked into the log file, it's too long to put here, but the last lines are like this:

MSI (c) (C8:08) [18:51:37:870]: RunEngine wait timed out
Installer is no longer responding.
1 Like

I suspect you may be running into a bug with the 7.7.0 MSI installer. I've documented a workaround:

1 Like

I thought that the reason the batch got an error was not giving "es.path.conf" in "ES_JAVA_OPTS".
Workaround :
Add the following to ES_JAVA_OPTS in elasticsearch-service.bat

I wrote an issue.

1 Like

Not just installer, but the .zip version had this problem too. Downgrading to 7.6.2 solved my problem

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.