Can't install Logstash-codec-nmap

I tried installing logstash-codec nmap see link:

I've tried installing using bin/plugin and I've also tried installing it using gem and also tried installing it from source.

But I keep getting an error: Please install ruby-nmap and gives a certain version that I should install. I'm not my server right now so I don't have the exact error. Anyone else having trouble with this?


More details: I'm on latest version of Ubuntu Server with updates installed and I have the latest version of Logstash.

I'm having the same problem. Oddly, I installed it about a month ago without issue. Both servers are running Ubuntu Server 14.04 with the OpenJDK 7 JRE. The working server is a slightly older version (7u101 vs 7u111). Both have logstash installed from the elastic repo, and is version 1:2.3.4-1.

Best I can tell, the plugin installation needs to install ruby-nmap, which now depends on ruby > 2.0.0, but the bundled jruby with logstash is 1.7.23. Is it possible to get the plugin to install an older version of ruby-nmap that doesn't depend on ruby 2?

For what it's worth, the problem is the same on Ubuntu 16.04 with OpenJDK 8.