Can't run logstash on Windows


(Mohanad) #1

Hello,

what I'm facing that I've downloaded logstash.zip, I've unzipped it to C drive
I've Elastic search and Kibana running on my machine but when I'm executing the following command on cmd

C:\logstash-6.4.2\bin>logstash -e 'input { stdin { } } output { stdout {} }'

I got the following response:

warning: ignoring JAVA_OPTS= -Xms1g -Xmx1g -XX:+UseParNewGC -XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOccupancyOnly -Djava.awt.headless=true -Dfile.encoding=UTF-8 -Djruby.compile.invokedynamic=true -Djruby.jit.threshold=0 -XX:+HeapDumpOnOutOfMemoryError -Djava.security.egd=file:/dev/urandom ; pass JVM parameters via LS_JAVA_OPTS

and nothing happen.

appreciate your kind input.


(Rahul Nama) #2

try this

bin/logstash -f [[your config file]].conf

for testing the config file, you can run

bin/logstash --config.test_and_exit -f <the config file>

(Mohanad) #3

please note that I've the same result

C:\Users\Administrator\Desktop\Logstash\logstash-6.3.0\bin>logstash -f logstash.conf

warning: ignoring JAVA_OPTS= -Xms1g -Xmx1g -XX:+UseParNewGC -XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOccupancyOnly -Djava.awt.headless=true -Dfile.encoding=UTF-8 -Djruby.compile.invokedynamic=true -Djruby.jit.threshold=0 -XX:+HeapDumpOnOutOfMemoryError -Djava.security.egd=file:/dev/urandom ; pass JVM parameters via LS_JAVA_OPTS


#4

Hello,
==> 1. Make sure you have java version 1.8+.
2.check in command prompt java -version
3. Make sure logstash.conf is a CONF file
4.keep in logstash.conf file
Ex;
input{stdin{}}output{stdout{}}
5. In command prompt,
cd logstash-6.3.0
bin\logstash -f logstash.conf


(Mohanad) #5

Hello,

Java version is 1.8.0_181

and the extension is .conf

when I execute this command for the first time

C:\logstash-6.3.0>bin\logstash -f logstash.conf

I got

\IBM\WebSphere was unexpected at this time.

when I execute the same again I got:

warning: ignoring JAVA_OPTS= -Xms1g -Xmx1g -XX:+UseParNewGC -XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOccupancyOnly -Djava.awt.headless=true -Dfile.encoding=UTF-8 -Djruby.compile.invokedynamic=true -Djruby.jit.threshold=0 -XX:+HeapDumpOnOutOfMemoryError -Djava.security.egd=file:/dev/urandom ; pass JVM parameters via LS_JAVA_OPTS

do you've any idea what should I do?


(Mohanad) #6

I've updated setup.bat and enabled the echo

I've this issue that is terminating the process

C:\logstash-6.3.0\bin>if not exist "C:\logstash-6.3.0\vendor\jruby\bin\jruby" ( echo "C:\logstash-6.3.0\vendor\jruby\bin\jruby" echo "could not find jruby in C:\logstash-6.3.0\vendor\jruby" 1>&2 rem exit /b 1 )

while I've took the pathC:\logstash-6.3.0\vendor\jruby\bin\jruby
it exist and accessable

any ideas !


(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.