Logstash does not start on windows 10


(Srinivasa Pola) #1

Hi -

I have logstash installed on windows 10 laptop.When I try to execute logstash using the command below , nothing happens and all see is the message below.

logstash -f logstash.conf --config.test_and_exit
warning: ignoring JAVA_OPTS=-Dcom.sun.xml.namespace.QName.useCompatibleSerialVersionUID=1.0 -Xms32m -Xmx64m ; pass JVM parameters via LS_JAVA_OPTS

Here is my conf file which is stored in bin directory.

input
{
file
{
path=>"D:/ELK_STACK/DATA/INPUT/input.log"
start_position=>"beginning"
}
}

output {
file {
path => "D:/ELK_STACK/DATA/OUTPUT/output.log"
codec => rubydebug
}
}

I have ued --config.debug on command line , but get the same message shown above.I have logstash 6.2.2 . I tried using 5.6.8 and got exact same message .Any Idea what I might be missing ?Any help is highly appreciated.

Thank you
Sri


(Magnus B├Ąck) #2

If you actually want to start Logstash rather than just test the syntax of the configuration and exit then don't use the --config.test_and_exit option.


(Srinivasa Pola) #3

Hi magnusbaek - Thank you for your response. I wanted to test the configuration , so I was using --config.test_and_exit . I also tried removing that and nothing happens.


(Mohammed Sanaulla) #4

Even I am facing the same issue.

On Logstash 5.5

logstash-5.5.0\bin>logstash
JAVA_OPTS was set to [-Xms3g -Xmx3g -XX:MaxPermSize=256M -XX:+UseConcMarkSweepGC -
XX:+UseParNewGC]. Logstash will trust these options, and not set any defaults that it might usually set
Java HotSpot(TM) 64-Bit Server VM warning: Ignoring option MaxPermSize; support was removed in 
8.0
Java HotSpot(TM) 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 
9.0 and will likely be removed in a future release.
Unrecognized VM option 'UseParNewGC'
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.

But on Logstash 5.6.8:

logstash-5.6.8\bin>logstash
warning: ignoring JAVA_OPTS=-Xms3g -Xmx3g -XX:MaxPermSize=256M -XX:+UseConcMarkSweepGC -
XX:+UseParNewGC; pass JVM parameters via LS_JAVA_OPTS

This means that logstash command for logstash 5.6.8 isn't recognised on Windows 10 while 5.5.0 is recognised.


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.