Can't set indices.fielddata.cache.size


(Luigi Tomaselli) #1

Hi,
i'm trying to set FieldData cache size in
/etc/elasticsearch/elasticsearch.yml with no success; this is a log extract:

[2014-01-11 13:04:39,890][DEBUG][indices.cache.filter ] [Egghead] using
[node] weighted filter cache with size [20%], actual_size [1010.6mb],
expire [null], clean_interval [1m]
[2014-01-11 13:04:39,891][DEBUG][indices.fielddata.cache ] [Egghead]
using size [-1] [-1b], expire [null]

[2014-01-11 13:04:39,909][DEBUG][gateway.local.state.meta ] [Egghead] using
gateway.local.auto_import_dangled [YES], with
gateway.local.dangling_timeout [2h]

so in IndicesFieldDataCache.java it can't get configured value.

Some info:

java -version
java version "1.7.0_45"
Java(TM) SE Runtime Environment (build 1.7.0_45-b18)
Java HotSpot(TM) 64-Bit Server VM (build 24.45-b08, mixed mode)

in elasticsearch.yml:
indices.fielddata.cache.size: 5%
indices.fielddata.cache.expire : 5m

Debian version 7.2, Elasticsearch 0.90.9

I have tried to set % or gb value, to prefix that two lines with "index."
ecc...

What's wrong?

Thank you,
Luigi

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/dc0d6145-8b95-4d98-bff8-c2f9a4c18141%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Luigi Tomaselli) #2

Fixed!, just found a preceding config line which start witth a white space
and so all consecutive lines get ignored.

Luigi

Il giorno sabato 11 gennaio 2014 13:15:35 UTC+1, Luigi Tomaselli ha scritto:

Hi,
i'm trying to set FieldData cache size in
/etc/elasticsearch/elasticsearch.yml with no success; this is a log extract:

[2014-01-11 13:04:39,890][DEBUG][indices.cache.filter ] [Egghead]
using [node] weighted filter cache with size [20%], actual_size [1010.6mb],
expire [null], clean_interval [1m]
[2014-01-11 13:04:39,891][DEBUG][indices.fielddata.cache ] [Egghead]
using size [-1] [-1b], expire [null]

[2014-01-11 13:04:39,909][DEBUG][gateway.local.state.meta ] [Egghead]
using gateway.local.auto_import_dangled [YES], with
gateway.local.dangling_timeout [2h]

so in IndicesFieldDataCache.java it can't get configured value.

Some info:

java -version
java version "1.7.0_45"
Java(TM) SE Runtime Environment (build 1.7.0_45-b18)
Java HotSpot(TM) 64-Bit Server VM (build 24.45-b08, mixed mode)

in elasticsearch.yml:
indices.fielddata.cache.size: 5%
indices.fielddata.cache.expire : 5m

Debian version 7.2, Elasticsearch 0.90.9

I have tried to set % or gb value, to prefix that two lines with "index."
ecc...

What's wrong?

Thank you,
Luigi

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/edded982-10a2-4d6b-b56f-a434389e6c54%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #3