Setting field data cache for query performance

One of the elasticsearch search query with aggregation, is taking more than 10s and getting timed out in my application. The data set being aggregated is very huge .As part of tuning the search query,I am trying to set indices.fielddata.cache.size, The API call returned error,
"error":{"root_cause":[{"type":"illegal_argument_exception","reason":"persistent setting [indices.fielddata.cache.size], not dynamically updateable"}],"type":"illegal_argument_exception","reason":"persistent setting [indices.fielddata.cache.size], not dynamically updateable"},"status":400}

So, tried setting this field in elasticsearch.yml and restarted as,
indices.fielddata.cache.size : 50%
How do I check if this got set correctly? curl http://localhost:9200/_cluster/stats is just giving
"fielddata": {
** "memory_size_in_bytes": 0,**
** "evictions": 0**
** }**

Please help.

I wonder if you can get this from ?

_nodes/stats also returns
"fielddata": {
"memory_size_in_bytes": 0,
"evictions": 0
This is not returning the value set in elasticsearch.yml file.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.