Can't Start ES 5.2 After Upgrade


(Kevin M.) #1

I just upgraded a VM from 5.0 to 5.2 and now can't start the service. I see this error at the command line after running "service elasticsearch start":

"If the number of processes is expected to increase from one, then you should configure the number of GC threads appropriately using -XX:ParallelGCThreads=n"

I had previously had similar issues when I went from 2.4 to 5.0 as detailed in this post:

What do I need to address this particular issue? Do I need to make an update to the /etc/elasticsearch/jvm.options file? If so, what changes should be made? Any help would be appreciated. Thanks.

Kevin


(Mark Walkom) #2

Is that what is in the ES log?
What OS? What JVM?


(Kevin M.) #3

No, I am seeing this right on the command line when trying to start the service. I don't see anything in the log files. I am running Centos 6.8 and Java 1.8.0_111. Thoughts on how to fix this??? Thanks.


(Jörg Prante) #4

See


(Kevin M.) #5

Thanks. I am going to add -XX:-AssumeMP to the jvm.options file. Do you know if there is any specific location I need to add it???


(Kevin M.) #6

Ok, so I added -XX:-AssumeMP to the jvm.options file and it got rid of my error at the top of this chain. However, now ES 5.2 appears to start when I run "service elasticsearch start" as root from the command line, but when I check the status of the service I see:

elasticsearch dead but pid file exists

I tried running the following command and it does not return anything:

netstat -ntlp | grep 9200

I also looked for the relevant file in /var/run/elasticsearch and it is not there. How do I fix this particular issue???

Kevin


(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.